ASRock.com Homepage
Forum Home Forum Home > Technical Support > HTPC&Gaming Barebone&Others
  New Posts New Posts RSS Feed - Beebox N3150 - Issues installing Win10 on mSATA
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Beebox N3150 - Issues installing Win10 on mSATA

 Post Reply Post Reply Page  12>
Author
Message
BuckoNZ View Drop Down
Newbie
Newbie


Joined: 02 Dec 2015
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote BuckoNZ Quote  Post ReplyReply Direct Link To This Post Topic: Beebox N3150 - Issues installing Win10 on mSATA
    Posted: 02 Dec 2015 at 2:52pm
Hi,

I have purchased an ASRock Beebox N3150. I have replaced the 2GB RAM, which came with the unit with 2x 4GB SODIMMS. I was hoping to get away with the onboard 32GB storage, but this was becoming an issue, so I purcahsed an AData 128gn mSATA drive.

I have a Windows 10 USB Installation drive. I put this into the Beebox and start going through the installation process.

When I go to select the mSATA drive in the list, it won't let me install Windows on this device and showed an error something along the lines of "We couldn't create a new partition or locate an existing one. For more information see the setup log files".

Research indicated that Windows 10 hates a pile of partitions and on the existing onboard storage there were about 4 partitions. So I deleted these. The issue persisted.

Follwojng other advise, I dropped into a command prompt and using DiskPart, I selected the drived, cleaned it, created an NTFS partition and set it as the active partition.

This time when I went through the installation process, a new message presented itself:
"Windows can't be installed on Drive 0 Partition 1 (Clcik here for more information)"

When you click on the More Information, I get a message saying Windows can't be installed onto my selected location and provided the error code: 0x80300001

Apparently this error code often shows when the Windows 10 USB Installation drive does have the right drivers for your device.

When I go to the ASRock website there are INF drivers, but they are a Windows executable - the raw files aren't there.

Where too from here!?!?
Back to Top
BuckoNZ View Drop Down
Newbie
Newbie


Joined: 02 Dec 2015
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote BuckoNZ Quote  Post ReplyReply Direct Link To This Post Posted: 02 Dec 2015 at 2:53pm
Oh, and I've also gone to the AData website to try and find drivers there, specifically for my mSATA drive but nothing can be found.
Back to Top
wardog View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 15 Jul 2015
Status: Offline
Points: 6447
Post Options Post Options   Thanks (0) Thanks(0)   Quote wardog Quote  Post ReplyReply Direct Link To This Post Posted: 02 Dec 2015 at 5:02pm
??? Why don't people put down model numbers when seeking help ???

What model of AData?

Kinda makes you wish you'd spent that extra $30-40 and gotten the 128GB BeeBox now, huh?
< id="kpm_plugin" ="application/x-KPMPlugin">
Back to Top
BuckoNZ View Drop Down
Newbie
Newbie


Joined: 02 Dec 2015
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote BuckoNZ Quote  Post ReplyReply Direct Link To This Post Posted: 03 Dec 2015 at 2:14am
It was an AData Premier Pro SP310.

However I resolved the issue.  The Windows USB Installation drive was built some 6 months ago. So knowing there was probably some updates I created a new Windows USB Installation drive and the installation went fine.
Back to Top
wardog View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 15 Jul 2015
Status: Offline
Points: 6447
Post Options Post Options   Thanks (0) Thanks(0)   Quote wardog Quote  Post ReplyReply Direct Link To This Post Posted: 03 Dec 2015 at 3:01am
Good deal. Glad to hear it ended up being something as simple as that.
< id="kpm_plugin" ="application/x-KPMPlugin">
Back to Top
WALAPONIC View Drop Down
Newbie
Newbie


Joined: 16 Dec 2015
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote WALAPONIC Quote  Post ReplyReply Direct Link To This Post Posted: 16 Dec 2015 at 12:50am
Regarding the N3150-2G32SW10/B/US , this is one with Windows 10 factory pre-installed

ASRock labling on the box:
mSATA = 32GB eMMC
HDD = none
memory = 2GB ,one module

I purchased this unit. It powered up perfectly and started Windows 10.
I added 2 x 4 GB Ram (now totalling 8GB) and Samsung 850 EVO 500 mSATA .
I formatted the EVO (SSD) as NTFS and left it "unallocated".
All the new hardware is recognized in the Device Manager and shows up in the Windows 10 File Exporer App under "This PC".

The 32 eMMC shows Useable 28.2 GB, free 4.85 GB .This is quickly used when adding files ,etc. or even merely tring to update the Windows 10 (notifications appear that there is not sufficient space to do the
upgrades)

I think MANY people who get this BeeBox would like to increase Ram , add an SSD and migrate Windows 10 to the SSD.

Before changing too much I would like to migrate the Windows 10 OS to my SSD. Has anyone done this ?
What is the EXACT procedure ? Is it necessary to change the BIOS ? Once done, do you delete Windows 10 from the eMMC ?

ANY help or insights into this would be greatly appreciated.
Back to Top
WALAPONIC View Drop Down
Newbie
Newbie


Joined: 16 Dec 2015
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote WALAPONIC Quote  Post ReplyReply Direct Link To This Post Posted: 29 Feb 2016 at 12:34pm
wardog,
You appear quite knowledgeable about the BeeBox. Do you have any suggestions for me, WALAPONIC, concerning my Post: 16 Dec 2015 at 12:50am ? Thank you.
Back to Top
Eric1957 View Drop Down
Newbie
Newbie


Joined: 26 Mar 2016
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Eric1957 Quote  Post ReplyReply Direct Link To This Post Posted: 26 Mar 2016 at 11:04pm
ASRock Beebox NUC Mini PC BEEBOX N3150-2G32SW10/B/US

Crucial MX200 500GB mSATA Internal Solid State Drive - CT500MX200SSD3

Crucial 16GB Kit (8GBx2) DDR3-1600 MT/s (PC3-12800) 204-Pin SODIMM Notebook Memory CT2KIT102464BF160B / CT2CP102464BF160B

If you want to run Windows 10 Home on the ASRock Beebox 3150N, it's more economical to buy the version that comes with Windows pre-installed.  You also get the 32 GB eMMC "drive" that is on the motherboard.  The barebones models do not come with the eMMC.  The problem is that Windows 10 Home is installed on that 32 GB eMMC drive.  It runs when you first get it, but after a few updates or software installs, you run out of room on the 32 GB eMMC drive.  You need to add a larger drive and move Windows 10 over to that larger drive.  Simple concept, but I spent a week working on it before finally succeeding.  For much of that week I thought I had an expensive brick that I would have to toss in the garbage.

My plan was to install a Crucial MX200 500 GB SSD in the mSATA slot as the main drive, and replace the single 2 GB memory module with 2 8 GB memory modules.  The mechanical work of installation and replacement was fairly straightforward.  I had not done this for a while, and one the first try I did not get one of the memory modules properly seated.  Be firm but gentle, when correctly angled they snap easily into place.  I had some trouble putting the Beebox cover back on.  It helps to gently squeeze 2 sides to get it to slide back into place.

Next I wanted to clone the eMMC drive onto the Crucial SSD ans make the SSD the boot drive.  Crucial provides a free license for Acronis software.  I've used Acronis before and it works great with hard drives.  My first problem was the fact that I had previously purchased Acronis software.  Acronis requires you to register with your email address to download the free copy.  But I already had an account with Acronis, so I needed to supply the password, long since forgotten.  I got the password reset and downloaded the free software.  It did not work, presumably it is not compatible with eMMC drives.  Some internet research led me to Macrium Reflect, a free version can be downloaded from macrium.com.  It worked, successfully cloning the eMMC drive to the SSD.

Now most experts recommend that you remove the original boot drive after cloning your boot drive, especially when running 64-bit Windows.  I believe this advice based on past experience with adding drives to Windows Vista PCs.  I added a second hard drive to a 32-bit Windows Vista laptop, cloning the original drive and making the new larger drive the boot drive.  I left the original drive in place, and it has run fine for years.  Later I did the same thing with a 64-bit Windows Vista desktop PC.  It ran fine for a week or 2, then suddenly it failed to boot.  I thought I had a dead PC, but then I went into the BIOS and set it to boot from the original boot drive.  It booted fine.  So there is something about 64-bit Windows that gets confused if the original boot drive is not removed.  The problem with the eMMC drive in the Beebox is that it is not removable.  My first thought was to download the Microsoft Windows 10 Media Creation Tool and do a clean install on the SSD.  At first I could not download it, because Microsoft does not allow a Windows Vista PC to download it, and it would not allow the Beebox to download it because there was not enough space left on the boot drive (space available on the SSD was ignored).  Then I went into Manage Disks, deleted the main partition on the eMMC, recreated it and then formatted it.  The eMMC is formatted as a GPT disk, and Windows Disk Management would not let me delete the other partitions (System, Recovery, Microsoft).  Windows would boot from the SSD, but there was clearly something wrong as it would generally lock up after several minutes and never succeeded in running Windows Update.  Nevertheless, I finally succeeded in downloading the Microsoft Windows 10 Media Creation Tool and created a bootable installation disk on a USB thumb drive.

The thumb drive would boot and run the setup program, but stopped before beginning the installation, with an error message that I have forgotten.  Then I used the setup program to delete the remaining partitions on the eMMC drive.  The setup program then proceed to install Windows 10 Home on the SSD without any further issues.  Product activation was automatic, apparently the activation code is not lost when the eMMC is completely erased.  I ended up with Windows 10 Home installed on my SSD, which is now the C: drive, and an empty 32 GB D: drive (the eMMC).  Windows Update ran smoothly, installing the 1511 update.
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (1) Thanks(1)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 08 Apr 2016 at 12:33pm
For the Beebox series of PCs, ASRock has supplied information and a special tool to assist owners with installing Windows 10 on another drive, if they have purchased a Beebox version that has Windows 10 included.

On the Beebox information page, in the FAQ section, there is a guide explaining how this is done. That is the second question in the FAQ, here:

http://www.asrock.com/nettop/Intel/Beebox%20Series/?cat=FAQ

The FAQ includes a link to a program that will display the Windows 10 product activation key, that can be downloaded here:

http://www.asrock.com/nettop/Intel/Beebox%20Series/?cat=Download&os=Win1064

Scroll down to the Utilities section to find the AsrProductKey ver:1.0.0 program.

This information has been available as long as the Beebox product page has existed. Sometimes if you look for something, you can find it. Wink

The problem that Eric1957 mentioned about installing Windows on a PC when more than just the target OS drive is powered on, is a real issue. It affects Windows versions at least as far back as Windows 7, and possible Vista and XP too.

What I will describe may not be exactly what Eric1957 encountered, but it will affect any PC with more than one HDD or SSD operating when Windows is installed. The difference between 32 and 64 bit versions of Windows that he mentions regarding this situation I can't comment on, since I've never used a 32 bit version of Windows. IMO, the 32 bit versions of Windows won't be any different.

The problem is caused by the Windows installation program itself. If more than one drive is detected by the Windows installation program, it will copy the boot partition (what Windows calls the System partition) onto a drive other than the target OS drive.

That leaves us with a Windows installation that is dependent upon two drives in the PC. If we later remove or format the drive with the boot/System partition on it, the PC will no longer boot.

This can be fixed by booting from your Windows installation media, and choosing the Repair option, or by creating a Windows Recovery disk, which can be a USB flash drive.

In the case of the Beebox PCs, it is the eMMC drive that is the other drive in it that the Windows installation program uses for the boot/System partition. Eric1957 deleted all the partitions from the eMMC drive before the Windows installation began, but it is quite likely that the boot/System partition was written to the eMMC drive. That can be easily confirmed with the Windows Disk Management feature, or the Diskpart tool.

The Window product key is stored in the BIOS/UEFI of the Beebox PCs, which is why it was not lost when the eMMC drive was formatted.

In general, Windows installations on home PCs are associated with the mother board in a PC.

Once you install a copy of Windows on a PC you built, or buy a PC with Windows pre-installed, you can install the same version of Windows on the same PC with a different storage drive without any problem with Windows activation. Once the PC is connected to the Internet, it will automatically try to activate Windows.

If you change the mother board in a PC, you will need to activate Windows again. That is possible as long as you are using the same version of Windows on one PC.

Depending upon the version of Windows you are using (Windows 7, 8, 8.1, 10), you may be prompted to enter the activation key at the beginning of the installation. Some versions of Windows (10) will allow you to skip entering the activation key. Other versions of Windows may not be as cooperative.

Pre-built PCs normally supply the Windows product activation key in some way with the PC.
Back to Top
kingsgambita View Drop Down
Newbie
Newbie


Joined: 16 Apr 2016
Location: NZ
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote kingsgambita Quote  Post ReplyReply Direct Link To This Post Posted: 16 Apr 2016 at 1:52pm
I cloned the EMMc onto a new 250 GB SSD using Macrium Reflect. It was all very easy, and now I can boot from the new SSD.

I've left the EMMC with Windows as it was - but should I be worried that if I reformat that or delete the windows files then I'll potentially have problems booting up from the new drive?

If so, what can I do about it?

Michael
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.094 seconds.