ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - NO POST NEED HELP
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

NO POST NEED HELP

 Post Reply Post Reply
Author
Message Reverse Sort Order
ThreeDee View Drop Down
Senior Member
Senior Member
Avatar

Joined: 24 Jul 2019
Location: Billings,MT
Status: Offline
Points: 2396
Post Options Post Options   Thanks (0) Thanks(0)   Quote ThreeDee Quote  Post ReplyReply Direct Link To This Post Topic: NO POST NEED HELP
    Posted: 02 Jul 2020 at 11:16am
5 beeps can be cpu or gpu error .. CPU will only install one way. Try reseating your video card, it should "click" into place when fully seated. Double check all your power connections to motherboard and video card ..

If still not coming to life .. try removing all the components from your case and hook up outside of the case and see if it boots properly
|Ryzen 5 5900|ASRock X570 Taichi-BIOS 4.60|2x16GB HyperX Predator RGB 3200@3600 1:1 IF|ASRock RX 6700XT|2 x PCIe 4.0 M.2 Drives for OS & Games|850 WTT Seasonic 80+ Titanium PSU|Noctua NH-D15|
Back to Top
Alex22513 View Drop Down
Newbie
Newbie


Joined: 01 Jul 2020
Location: US
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alex22513 Quote  Post ReplyReply Direct Link To This Post Posted: 01 Jul 2020 at 7:54am
Just built a new PC and can't get the post, have tried switching ram. Taking out the battery etc. I put in the speaker and get 5 short beeps for a bad CPU I tried to look for bent pins but there were none. I also made sure it was in the right way. Here are my specs please help!!!

CPU: 3700x
MOBO: B550 Steel Legend
GPU: 5700 XT
NVME DRIVE
2TB HDD
PSU: 700W Cooler Master
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.238 seconds.