ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - AMD FM2A88XExtreme6+ Sound??
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

AMD FM2A88XExtreme6+ Sound??

 Post Reply Post Reply Page  12>
Author
Message Reverse Sort Order
306bobby View Drop Down
Newbie
Newbie


Joined: 10 Jan 2016
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote 306bobby Quote  Post ReplyReply Direct Link To This Post Topic: AMD FM2A88XExtreme6+ Sound??
    Posted: 13 Jan 2016 at 8:19am
Originally posted by wardog wardog wrote:

Originally posted by 306bobby 306bobby wrote:

...I rebuilt it 5 minutes ago and the front sound ports on the case are still unworking. The back speaker output is a great amount louder though. Should I still return it or maybe wait a few days and see what happens?


Bobby, you're saying there that something has changed between when you initially posted and now, that there is a difference since "5 minutes ago" ?


If that is true, please do an out of the case bench build of it and see if any thing changes again. Place the motherboard directly on the ASRock box it came with.

On the plain box. DO NOT place anything between the bottom of the motherboard and the ASRock box.



Thanks but I believe that my speakers had not been turned all the way up. It is still quiet so I am gonna go through with the RMA
Back to Top
wardog View Drop Down
Moderator Group
Moderator Group


Joined: 15 Jul 2015
Status: Offline
Points: 6447
Post Options Post Options   Thanks (0) Thanks(0)   Quote wardog Quote  Post ReplyReply Direct Link To This Post Posted: 12 Jan 2016 at 4:28pm
Originally posted by 306bobby 306bobby wrote:

...I rebuilt it 5 minutes ago and the front sound ports on the case are still unworking. The back speaker output is a great amount louder though. Should I still return it or maybe wait a few days and see what happens?


Bobby, you're saying there that something has changed between when you initially posted and now, that there is a difference since "5 minutes ago" ?


If that is true, please do an out of the case bench build of it and see if any thing changes again. Place the motherboard directly on the ASRock box it came with.

On the plain box. DO NOT place anything between the bottom of the motherboard and the ASRock box.
Back to Top
306bobby View Drop Down
Newbie
Newbie


Joined: 10 Jan 2016
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote 306bobby Quote  Post ReplyReply Direct Link To This Post Posted: 12 Jan 2016 at 9:42am
Originally posted by Xaltar Xaltar wrote:

I would try returning it to the store you purchased it from first and hope they exchange it for you. If that fails then you can try ASRock directly.

Ok! But I haven't returned it yet. I have all the info ready. I am wondering, I rebuilt it 5 minutes ago and the front sound ports on the case are still unworking. The back speaker output is a great amount louder though. Should I still return it or maybe wait a few days and see what happens?
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 23693
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 2016 at 2:29am
I would try returning it to the store you purchased it from first and hope they exchange it for you. If that fails then you can try ASRock directly.
Back to Top
306bobby View Drop Down
Newbie
Newbie


Joined: 10 Jan 2016
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote 306bobby Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 2016 at 2:26am
Originally posted by Xaltar Xaltar wrote:

If you can RMA still then do so. The damage may not be restricted to the onboard amp and could worsen in time. Always return a damaged product when you can, believe me you do not want to get out of warranty and then have it fail.

Could u give me some instructions to RMA? The instructions on Tha asrock website were a little confusing to me
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 23693
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 2016 at 2:03am
If you can RMA still then do so. The damage may not be restricted to the onboard amp and could worsen in time. Always return a damaged product when you can, believe me you do not want to get out of warranty and then have it fail.
Back to Top
306bobby View Drop Down
Newbie
Newbie


Joined: 10 Jan 2016
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote 306bobby Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 2016 at 1:42am
Originally posted by wardog wardog wrote:

Originally posted by 306bobby 306bobby wrote:

Now I do have one question about this though. I understand that this is probably very messed up, but the HD audio output for the front inputs on the case is the only thing all crackly at the moment. The normal ports on the mobo sound great, just very very quiet


Meh, don't waste your time.

The below says it all:
Originally posted by 306bobby 306bobby wrote:

<span style="line-height: 16.8px; : rgb43, 43, 43;"></span>...., there
was an electricity discharge on the mobo, directly where the Purity
Sound is located.


Yea. That was bad. RMA the board and don't waste any more of your time.

Get in the good habit of always unplugging? power and discharge it whenever/each and every time you take the cased side panel(s) off.


Ok but the rest of the board still works. Do you think it would be fine to just get a different sound card?
Back to Top
wardog View Drop Down
Moderator Group
Moderator Group


Joined: 15 Jul 2015
Status: Offline
Points: 6447
Post Options Post Options   Thanks (0) Thanks(0)   Quote wardog Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2016 at 8:10pm
Originally posted by 306bobby 306bobby wrote:

Now I do have one question about this though. I understand that this is probably very messed up, but the HD audio output for the front inputs on the case is the only thing all crackly at the moment. The normal ports on the mobo sound great, just very very quiet


Meh, don't waste your time.

The below says it all:
Originally posted by 306bobby 306bobby wrote:

...., there was an electricity discharge on the mobo, directly where the Purity Sound is located.


Yea. That was bad. RMA the board and don't waste any more of your time.

Get in the good habit of always unplugging  power and discharge it whenever/each and every time you take the cased side panel(s) off.
Back to Top
306bobby View Drop Down
Newbie
Newbie


Joined: 10 Jan 2016
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote 306bobby Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2016 at 4:20pm
Now I do have one question about this though. I understand that this is probably very messed up, but the HD audio output for the front inputs on the case is the only thing all crackly at the moment. The normal ports on the mobo sound great, just very very quiet
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 23693
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2016 at 4:02pm
Sadly there is no simple fix. If the amp is blown you will either need to hook up a preamp to the audio output then the speakers to that (in essence replacing the onboard amp) or get a new add in sound card. The problem with the preamp solution is that you will likely get a lot of hiss and crackle, especially if the damaged onboard amp causes signal noise because it is broken. 

A very quick and dirty way to create a preamp is to use one set of speakers connected to the audio output then hook up another to that speaker set's headphone jack, that will give you 2 volume controls. As I said above though, it is very likely that the sound will be dirty.
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.188 seconds.