ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - b450 pro4 m.2 nvme is not detecting
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

b450 pro4 m.2 nvme is not detecting

 Post Reply Post Reply Page  <12
Author
Message
muziqaz View Drop Down
Groupie
Groupie
Avatar

Joined: 04 Jan 2021
Location: London
Status: Offline
Points: 590
Post Options Post Options   Thanks (0) Thanks(0)   Quote muziqaz Quote  Post ReplyReply Direct Link To This Post Posted: 20 Feb 2021 at 4:55pm
ok. in Advanced\AMD PBS settings:
PCIe/GFX Lanes configuration what other options does it give? If it is just x8, select that.

Promontory PCIe Speed select max it let's you
M.2 PCIe speed - what option does that give?
folding@home
Back to Top
cah4e34 View Drop Down
Newbie
Newbie


Joined: 17 Feb 2021
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote cah4e34 Quote  Post ReplyReply Direct Link To This Post Posted: 21 Feb 2021 at 10:38am
Please look at the new photos that I have uploaded to google drive. I also noticed that the disk is in the PC for some reason cold, so it should be? I found information that this may be due to the power supply, that the slot may not have enough power. https://drive.google.com/drive/folders/11ez5rbWJYKysOuDsbXrnTppsEyiYJgPe?usp=sharing
Back to Top
muziqaz View Drop Down
Groupie
Groupie
Avatar

Joined: 04 Jan 2021
Location: London
Status: Offline
Points: 590
Post Options Post Options   Thanks (0) Thanks(0)   Quote muziqaz Quote  Post ReplyReply Direct Link To This Post Posted: 21 Feb 2021 at 5:59pm
Ah, the second photo is most interesting ;)
Select x8x4x4
3rd photo Gen 3
4th Gen 2

Power supply first hits GPUs and other devices before even thinking to reject SSD. SSDs use tiny amount of power compared to other components. And system will be unstable if you had power issues.
What PSU are you running
folding@home
Back to Top
cah4e34 View Drop Down
Newbie
Newbie


Joined: 17 Feb 2021
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote cah4e34 Quote  Post ReplyReply Direct Link To This Post Posted: 23 Feb 2021 at 12:48am
Unfortunately, it didn't help either. Today I tested the drive on another PC (Ryzen 7 2700x, Asus b450 tuf pro gaming) and I want to say that it works great. Then I checked on another PC that is identical to mine, but it did not work. Very strange is it really not compatible with my motherboard? I wrote in support of Asro?k, they did not say anything about compatibility. Are there any other options? ((((

P.s Gamemax GE600 power supply
Back to Top
muziqaz View Drop Down
Groupie
Groupie
Avatar

Joined: 04 Jan 2021
Location: London
Status: Offline
Points: 590
Post Options Post Options   Thanks (0) Thanks(0)   Quote muziqaz Quote  Post ReplyReply Direct Link To This Post Posted: 23 Feb 2021 at 2:07am
I always wondered, what could possibly stop Asrock supporting SSD drives? We never needed checking HDD support in the past, or SATA SSDs
folding@home
Back to Top
cah4e34 View Drop Down
Newbie
Newbie


Joined: 17 Feb 2021
Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote cah4e34 Quote  Post ReplyReply Direct Link To This Post Posted: 23 Feb 2021 at 2:33am
Now I don't know what to do ((I asked the support to find out if there were many problems like mine and asked if there would be BIOS updates in the near future for my motherboard. I have not received an answer yet, I think that ssd is incompatible with my motherboard. Perhaps the problem lies elsewhere (
Back to Top
CHuser View Drop Down
Newbie
Newbie


Joined: 25 Jul 2021
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote CHuser Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jul 2021 at 6:51pm
Hi, I had the same issue with Kioxia Exceria nvme.

Asrock support confirmed it's not compatible with the B450 Pro4.

In the end had to get a PCIE riser card (PCI Express 4.0 x 4,32Gbps,for NVME) install the Kioxia nvme with it on PCIE slot 2,
re-flash the bios - riser+nvme card installed when flashing bios
set the PCIE/GFX lane config to 4x4x

The bios for this board is currently version 5.00, released in May 2021.

CSM is On for UEFI only (both options), Secure Boot disabled.

For my case without flashing the bios again, the riser card/nvme is recognized in bios, but neither linux/windows is able to detect it when trying to do fresh install or check from existing working boot environment. This is despite clearing the cmos.

Took me on off a month to sort this out, not ideal, but at least got it to work.

Hope it helps those struggling with this, and to echo what others have commented, check on the compatibility first before buying, even though its Year 2021, and all the marketing specs indicated it should work.

All the best.
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.094 seconds.