ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Graphics Card
  New Posts New Posts RSS Feed - (Solved)ASRock RX6800 Challenger Poor Performance
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

(Solved)ASRock RX6800 Challenger Poor Performance

 Post Reply Post Reply Page  12>
Author
Message
picmanjoe View Drop Down
Newbie
Newbie
Avatar

Joined: 17 Jan 2021
Location: Georgia, USA
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote picmanjoe Quote  Post ReplyReply Direct Link To This Post Topic: (Solved)ASRock RX6800 Challenger Poor Performance
    Posted: 17 Jan 2021 at 8:35am
Just finished a build and everything is running great except the GPU. I've tried uninstalling the Radeon drivers, overclocking the GPU, undervolting the GPU, and overclocking the VRAM in various combinations. Though I get about a max increase in performance of 8-12% by doing this, the benchmarks I've run (userbenchmark, 3D Mark, etc., have me at no more than the 4th percentile of all cards of this model. I've also tried rolling back to an earlier version of drivers with no impact. The card seems to hit the specified manufacturer speeds during gameplay (1900MHz on average), and things generally run well, but I worry that I'm leaving 20% of the card's performance on the table (just to get to the 50th percentile of all cards). If anyone has any ideas on what might be happening here, I would appreciate your thoughts.

System config:
MSI MAG x570 Tomahawk MB
16MB (x2) GSkill 3600 memory
Samsung 970 Evo Plus 1TB boot/game drive
ASRock RX 6800 Challenger Pro 16G OC
LG 27GN850 monitor (1440p, 144hz native)

Edited by ASRock_TSD - 14 May 2021 at 3:01pm
Back to Top
siropo View Drop Down
Newbie
Newbie
Avatar

Joined: 30 Jan 2021
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote siropo Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jan 2021 at 1:17am
Same issue here. I have ASRock Radeon RX 6800 XT Phantom Gaming D OC and I have poor results in performance majored in benchmarks and games. For example, in https://www.userbenchmark.com/UserRun/39154019 the maximum result which I can achieve is 122% overall with the maximum overclock while other models like MSI, Sapphire, etc. achieve much more like 140 - 150%. If you search in the results only the Asrock models have a 119-122% score. Another issue that I have is when I start recording the gameplay with OBS or Relive the I receive a black screen and I think it's a GPU hardware problem. I have tried everything - drivers, fresh installation, and even on a different computer. It's very annoying
Back to Top
picmanjoe View Drop Down
Newbie
Newbie
Avatar

Joined: 17 Jan 2021
Location: Georgia, USA
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote picmanjoe Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jan 2021 at 4:38am
Sorry to hear that. Just ran userbenchmark again and got a 110%, or 0th percentile of my card type. I wrote ASRock tech support (twice). The second time they just sent me instructions for an RMA when I was just asking for some troubleshooting help. So I'm shipping it back Monday. I'll let you know if the replacement is any better. Might be an avenue to explore.
Back to Top
siropo View Drop Down
Newbie
Newbie
Avatar

Joined: 30 Jan 2021
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote siropo Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jan 2021 at 4:42am
110% is an even worse result than mine. OK, please let me know if you find something in feather research
Back to Top
siropo View Drop Down
Newbie
Newbie
Avatar

Joined: 30 Jan 2021
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote siropo Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jan 2021 at 4:44am
one more thing, did you try to record your gameplay with ReLive? Please, try and tell me if you have any recording issues. Thank you!
Back to Top
siropo View Drop Down
Newbie
Newbie
Avatar

Joined: 30 Jan 2021
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote siropo Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jan 2021 at 5:29am
Look at these screenshots for the official results. All Asrock benchmarks are very bad overall compared with the other brands and even with the reference card.
I have tested Watch dogs: Legion as well and my benchmark average fps is 63 FPS at ultra settings 1440p RTX off with maximum possible overclock. A friend of mine with the Sapphire model gets with the same settings 73 FPS average. This is a 15% decrease in the performance and this is in all Asrock models,
Back to Top
picmanjoe View Drop Down
Newbie
Newbie
Avatar

Joined: 17 Jan 2021
Location: Georgia, USA
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote picmanjoe Quote  Post ReplyReply Direct Link To This Post Posted: 01 Mar 2021 at 9:13am
OK, so I RMA'd the card. At first they said they'd issue a refund and I said please just send me another card. Their response? Don't know when we'll be getting more in. I said at least test the card and they said OK. The card came back "unstable" and they just cut me a check even though I gave them several options to help me out as I'm dead in the water with a card. Fortunately I lucked out on 3060 launch day and and have an EVGA 3060 XC Gaming coming this week. Not where I want to be, but at least I'll be operational if/until the queue gets me a 3060 ti or 3070. I am also in the queue for a 3080 but I don't have the PSU for it. If you dm me I'd be happy to keep in touch when/if I get notified to buy.

So lesson learned with ASRock: during this time of limited supply, don't count on getting a replacement when you RMA a card. It was not good customer care at all. Kind of glad I'm moving on from ASRock, especially with the apparently generally poor performance on benchmarks.
Back to Top
siropo View Drop Down
Newbie
Newbie
Avatar

Joined: 30 Jan 2021
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote siropo Quote  Post ReplyReply Direct Link To This Post Posted: 01 Mar 2021 at 3:40pm
I suggest that all ASRock RX 6800 models have the same performance issue with the clock speed. I measure the results in 3D mark as well and the results are also 15% less than the average score and this is for all ASRock RX 6800 models and everyone can verify this. As you can see on the first screenshot my average clock speed is only 1745 Mhz even with overclocking. On the second picture, you can see that the average score of RX 6800 is 13886 and mine is 12681 which is 15% less. Please, it will be usefully if more people do the test and confirm that.



Back to Top
IamNutReal View Drop Down
Newbie
Newbie


Joined: 11 May 2021
Location: Amsterdam
Status: Offline
Points: 95
Post Options Post Options   Thanks (0) Thanks(0)   Quote IamNutReal Quote  Post ReplyReply Direct Link To This Post Posted: 11 May 2021 at 4:43pm
Hello guys, i'm actually having the same situation as your and wanted to know if you figured out where does the problem come from so far?

Thanks.
Back to Top
siropo View Drop Down
Newbie
Newbie
Avatar

Joined: 30 Jan 2021
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote siropo Quote  Post ReplyReply Direct Link To This Post Posted: 11 May 2021 at 4:51pm
I think that all owners of these models have this performance issue and most people just don't know. I'm mining with the card and because the profit of mining is still high I keep the card. When the mining prices drop I will send it for reclamation
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.063 seconds.