ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed -  X99M Killer windows under uefi mode
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X99M Killer windows under uefi mode

 Post Reply Post Reply
Author
Message Reverse Sort Order
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Topic: X99M Killer windows under uefi mode
    Posted: 23 Jan 2016 at 3:06pm
Originally posted by looproll looproll wrote:

Hello, i m trying to install windows 10 under uefi mode in my X99M Killer motherboard, i have  core i7 5820K, GeForce GTX 980 and my ssd is Samsung 850 EVO, and 16Gb ram, all  my hardware meets the specifications to install windows under uefi mode, i made a bootable usb with rufus and Gpt selection from the menu i tried 3 different usb drives, i entered in uefi bios i disabled CSM, i followed every possible step i found around the net, i have the latest bios versions in  my hardware i dont have a dvd-r drive and not any other disc connected to my rig.
After All of this the system ingores booting from uefi usb and in bios when i disabling CSM my ssd is dissarearing and only my flash drive is visible, i dont know what elese to try every help is important to me
P.S. My english are not so anvanced so for some mistakes in writing please be gentleSmile


I think you made a mistake making the bootable USB flash drive. The USB flash drive itself is not formatted as GPT, it is FAT32.

I don't know why Rufus even has the "GPT partition scheme for UEFI computers" as an option. Is that what you wrote about?

Are you using a Windows 10 64bit ISO file with Rufus? You must use that with Rufus or the manual method.

I use the manual method of creating the USB flash drive, which works perfectly, and there is nothing done to tell the Windows installer to use GPT partitioning.

I started doing UEFI booting installations with this guide. Try using Option 2 to create the USB flash drive, you do not need Rufus to do this. Or follow their way of using Rufus:

http://www.eightforums.com/tutorials/15458-uefi-bootable-usb-flash-drive-create-windows.html

How big are your USB flash drives? If they are larger than 16GB, they will not work correctly.

When you have the USB flash drive ready, do this: In the BIOS, change any options you must set, like RAID. You must be in AHCI or RAID mode, never use IDE. Set CSM to Disabled. Put the USB flash drive into a USB port on the board's IO panel.

Then Save and Exit the BIOS, but go right back into the BIOS when the PC restarts.

Go to the Boot screen, and find the entry for your flash drive that is, "UEFI: <flash drive name>", where flash drive name is whatever it is called in the BIOS. You must select the "UEFI" entry, as you seem to know, as the device you want to boot from to install Windows.

It does not matter if your SSD is not shown in the boot order, don't worry about that. All that matters is it will be seen by the Windows installation program.

Once the Windows installation is running, I choose a Custom installation. That screen will show your 850 EVO. If it has any partitions on it, delete them. Then click on New to format the SSD. A message will appear about creating new partitions. Click Ok, and you should get four partitions created automatically. Then just click Next to continue the installation.

Don't give up on using UEFI booting. I've been doing it for years now with SATA SSDs, and now PCIe SSDs. It is well worth it to do a UEFI booting installation. The installation will still boot with CSM set to Enabled, an MBR partition is added (hidden) by the installation program.

Your hardware is all fine for UEFI booting. If you need more help, let me know.


Back to Top
looproll View Drop Down
Newbie
Newbie


Joined: 08 Jan 2016
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote looproll Quote  Post ReplyReply Direct Link To This Post Posted: 08 Jan 2016 at 7:06pm
Hello, i m trying to install windows 10 under uefi mode in my X99M Killer motherboard, i have  core i7 5820K, GeForce GTX 980 and my ssd is Samsung 850 EVO, and 16Gb ram, all  my hardware meets the specifications to install windows under uefi mode, i made a bootable usb with rufus and Gpt selection from the menu i tried 3 different usb drives, i entered in uefi bios i disabled CSM, i followed every possible step i found around the net, i have the latest bios versions in  my hardware i dont have a dvd-r drive and not any other disc connected to my rig.
After All of this the system ingores booting from uefi usb and in bios when i disabling CSM my ssd is dissarearing and only my flash drive is visible, i dont know what elese to try every help is important to me
P.S. My english are not so anvanced so for some mistakes in writing please be gentleSmile
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.250 seconds.