ASRock.com Homepage
Forum Home Forum Home > Technical Support > HTPC&Gaming Barebone&Others
  New Posts New Posts RSS Feed - Deskmini H470 Audio and Wifi Issues
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Deskmini H470 Audio and Wifi Issues

 Post Reply Post Reply
Author
Message
wing View Drop Down
Newbie
Newbie
Avatar

Joined: 28 May 2021
Location: Hong Kong
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote wing Quote  Post ReplyReply Direct Link To This Post Topic: Deskmini H470 Audio and Wifi Issues
    Posted: 28 May 2021 at 2:11pm

My Deskmini
Deskmini H470
Intel 6 Cores Threads Core i5-11400 2.6GHz
Kingston 500GB A2000 Series M2 NVME 3D NAND PCIe SSD
Kingston 16GB KCP432SS8/16 DDR4 3200MHz
ASRock AS-AC-Deskmini AX200 WiFi6 Bluetooth 5.0 M.2 Card Module
Windows 10 64

My new Deskmini H470 can't success install the Audio and Network driver.

It has a red X show on the speaker and network icon on the window right corner.

And no show the wifi icon in order to connect my wifi

so I'm not sure what other steps to take. Are there any other solutions, or need a new driver.


wing
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 8412
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 31 May 2021 at 4:58pm
Dear Wing,

Thank you for posting your query to the ASRock forum.

Regarding your question, please make sure that the BIOS version you have is 2.10.
https://www.asrock.com/nettop/Intel/DeskMini%20H470%20Series/#BIOS

Once confirmed that, please install the 3.5mm audio device to the front and rear panel.

Install the Realtek audio driver from the link below:
https://www.asrock.com/nettop/Intel/DeskMini%20H470%20Series/#Download

For the WiFi, please reinstall the WiFi module to the system. Please also make sure that antenna cables are installed properly and antennas for the WiFi are installed.
Once done that, please try to install the 22.30.0 driver from the link below:
https://ark.intel.com/content/www/tw/zh/ark/products/189347/intel-wi-fi-6-ax200-gig.html



With thanks,
ASRock TSD

Edited by ASRock_TSD - 31 May 2021 at 5:00pm
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.203 seconds.