ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X570 Taichi Razer edition not showing in Synapse
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X570 Taichi Razer edition not showing in Synapse

 Post Reply Post Reply
Author
Message
sierra_stop View Drop Down
Newbie
Newbie


Joined: 05 Jun 2021
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote sierra_stop Quote  Post ReplyReply Direct Link To This Post Topic: X570 Taichi Razer edition not showing in Synapse
    Posted: 05 Jun 2021 at 1:51pm
G'day all,

I recently did a BIOS update to ver 4.30 and have noticed that the X570 no longer appears in Razer Synapse.

I've had similar issues in the past with razer devices not appearing which usually just required a bit of a usb switch around.

Anybody encountered this before and know of an issue? Rather not go backwards to an older BIOS version...
Back to Top
ThreeDee View Drop Down
Senior Member
Senior Member
Avatar

Joined: 24 Jul 2019
Location: Billings,MT
Status: Offline
Points: 2186
Post Options Post Options   Thanks (0) Thanks(0)   Quote ThreeDee Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jun 2021 at 6:33pm
You flashed the wrong BIOS .. 4.30 is for the non-Razor Taichi .. you need the BIOS for the Razer Edition
https://www.asrock.com/mb/AMD/X570%20Taichi%20Razer%20Edition/Specification.asp#BIOS
|Ryzen 5 5800x|ASRock X570 Taichi-BIOS 4.30|2x16GB HyperX Predator RGB 3200@3600 1:1 IF|ASRock RX 6700XT|2 x PCIe 4.0 M.2 Drives for OS & Games|850 WTT Seasonic 80+ Titanium PSU|Noctua NH-D15|
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.063 seconds.