ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - B450m pro4 runs m.2 Ultra on x2
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

B450m pro4 runs m.2 Ultra on x2

 Post Reply Post Reply
Author
Message
raein View Drop Down
Newbie
Newbie


Joined: 19 Jul 2021
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote raein Quote  Post ReplyReply Direct Link To This Post Topic: B450m pro4 runs m.2 Ultra on x2
    Posted: 19 Jul 2021 at 9:42pm
Hey guys

I've bought a samsung 970 evo 500 and installed it into ultra m.2 slot(M2_1). Read/write speeds are nothing like on google(1700/700 at best), otherwise disk looks fine. I've noticed that Samsung Magician indicated "Interface: PCIe Gen3 x2" for it, but my understanding is that it should be at x4. I figure this is the reason for low speeds, but just can't make it change.

What i've already done:
1. Manually installed EVO drivers from samsung site.
2. Updated BIOS to the latest version.
3. Loaded BIOS defaults.
4. Physically reinstalled disk. (I've stumbled on a thread from a guy with the exact same problem and re-installation did it for him)

Still same results.

My specs:
Asrock B450m pro4
Ryzen 5 3600
2x8 Adata ram at 3200 xmp
Zotac 1080ti installed in PCIE2 slot
One regular SATA SSD and one HDD

Thanks in advance
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 4972
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jul 2021 at 6:35pm
Dear Raein,
Thank you for the posting.

Today we took the similar config and BIOS P5.20 to test, but didn't reproduce the issue.
We use CrystallDiskInfo to check the Transfer Mode and our 970 EVO can run at PCIe 3.0 x4 properly.

For you system, we would like to provide some suggestions for you to verify.
1. Clear CMOS by referring to user manual page. 26.
User manual: https://download.asrock.com/Manual/B450M%20Pro4.pdf
2. Keep BIOS setting default and only install CPU, PSU, Cooler, RAM, Graphic card, 970 EVO to test.
3. Reinstall a clean Win10 OS.
4. If possible, please use other SSD to cross test.

Thank you,

Best wishes,
ASRock TSD
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.031 seconds.