ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X570 Taichi Stability Issues
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X570 Taichi Stability Issues

 Post Reply Post Reply
Author
Message
xepmoto View Drop Down
Newbie
Newbie


Joined: 07 Apr 2021
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote xepmoto Quote  Post ReplyReply Direct Link To This Post Topic: X570 Taichi Stability Issues
    Posted: 23 Jul 2021 at 2:49am
Hi,

I've been having issues with my ASRock X570 Taichi + 5900X since I've put them together earlier this year. I get periodic reboots. Various MCEs are logged such as (each is a separate occurrence)

mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 27: faa000000000080b
mce: [Hardware Error]: CPU 4: Machine Check: 0 Bank 5: bea0000001000108
mce: [Hardware Error]: CPU 4: Machine Check: 0 Bank 1: bc800800060c0859

[Hardware Error]: Uncorrected, software restartable error.
[Hardware Error]: CPU:3 (19:21:0) MC0_STATUS[-|UE|MiscV|AddrV|-|-|-|-|Poison|-]: 0xbc00080001010135
[Hardware Error]: Error Addr: 0x00000008aa9a1340
[Hardware Error]: IPID: 0x001000b000000000
[Hardware Error]: Load Store Unit Ext. Error Code: 1, An ECC error or L2 poison was detected on a data cache read by a load.
[Hardware Error]: cache level: L1, tx: DATA, mem-tx: DRD

Some of the MCEs like faa000000000080b remind me of earlier Ryzen C6-related crashes in Linux. Others are related to L2 cache poison. The C6 related issues could usually be fixed by settings "Power Supply Control" to "Typical Current Idle" in the BIOS, but I have not had any luck with this board in particular.

I'm leaning towards the issue being with the actual CPU, though I'm wondering if ASRock could have missed anything with the "Power Supply Control" setting for the BIOS on this board.

Below I will list what I have tried so far:

- Updating BIOS. I visit ASRock's website several times a week to check for BIOS updates. I've gone through many.
- Latest AMD CPU microcode. Verified. Running 0x0a201016
- RAM. I have tried various RAM, including RAM from the QVL.
- BIOS settings. I have tried all sorts of BIOS settings from defaults to defaults with stability enhancements. I've tried setting the LLCs to level 1, for example.
- New Linux kernels. I have been using Linux for 20+ years and am very familiar with it. I regularly look for new kernel releases to see if there are any interesting fixes.
- Disabling C6 on startup via ZenStates.py

What does appear to work:

- Disable Core Performance Boost. Unfortunately this is a bad option because of the performance hit.

Going through the above list, I am pretty sure that the issue may be with the AMD Ryzen 5900X. But I was wondering if anyone had any other ideas. It's a little odd to see MCEs relating to Ryzen/C6 issue when the correct BIOS options have all been set to mitigate that.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.047 seconds.