ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X570 4.60Bios lost 600points in CB20
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X570 4.60Bios lost 600points in CB20

 Post Reply Post Reply
Author
Message
Newrockuser View Drop Down
Newbie
Newbie
Avatar

Joined: 26 Sep 2019
Location: Belgium
Status: Offline
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote Newrockuser Quote  Post ReplyReply Direct Link To This Post Topic: X570 4.60Bios lost 600points in CB20
    Posted: 13 Sep 2021 at 2:13am
Hi,

I'm an old school PC builder in my mid 40's who is of the principle don't fix it unless its broken so I was running a very old bios version 1.21 to be exact. I Recently installed a 3080 RTX and found there might be a need to update the bios so I did and I am now running 4.60

Previously in Cinebench my 3700X was hitting 4.15 Ghz on all cores with peeks of up to 4.5 Ghz. Cinebench 20 was scoring in the 4800's with the occasional 4900. Now all cores constantly hover around 4 Ghz and they are not boosting over 4.2 Ghz. Cinebench scores dropped into the low 4200 range. That performance hit is just a bit too big for me % wise.

Here is my problem, the menu structure in the bios changed and I tried to replicate my previous settings but I must be missing something as I don't seem to get my cores to boost upto 4.4 ghz.

If there is anyone willing to communicate with me on it or possibly share their own settings as a baseline for me to work with I'd be more than appreciative.
Back to Top
Khun_Doug View Drop Down
Senior Member
Senior Member
Avatar

Joined: 29 Mar 2020
Location: Poconos PA
Status: Offline
Points: 1025
Post Options Post Options   Thanks (0) Thanks(0)   Quote Khun_Doug Quote  Post ReplyReply Direct Link To This Post Posted: 13 Sep 2021 at 2:29am
Newrockuser,

I suppose I too am an old-school PC builder. I am a retired IT Admin with over 30 years experience with my hands on the hardware. I'm approaching 60 and still love this stuff.

You don't mention the specific motherboard. I have the X570 Creator. From the BIOS version you mention, I am guessing you have the X570 Taichi. If not, you will be able to take the information provided and use it appropriately on whatever motherboard you do have.

Asrock has a utility called A-Tuning. The software download is Asrock Motherboard Utility. If you do not yet have that installed, grab the latest copy and install. Using that, go to the OC Tweaker tab. You will see the current settings on your motherboard. From here you can try various overclock settings. Try making some small changes and rerun CB20. Watch your CPU voltage as too much will create excessive heat, and too little will cause crashes or PC reboots.

A few words on the A-tuning utility. First, it does not work with Precison Boost and per-core settings. If you want to use that, you will need to deal with the BIOS. Second is a strong suggestion that once you settle on specific settings, you run something Prime95 to stress test the CPU. You want to be sure the CPU cooler can properly keep the CPU cool. You also want to be sure Prime95 does not have any threads that die, indicating the CPU settings are not stable. When using Prime95, I don't bother with the memory stress, only the CPU test. You should be able to let Prime95 run for a few minutes without the CPU getting too hot, and all cores being stable.
Back to Top
Newrockuser View Drop Down
Newbie
Newbie
Avatar

Joined: 26 Sep 2019
Location: Belgium
Status: Offline
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote Newrockuser Quote  Post ReplyReply Direct Link To This Post Posted: 13 Sep 2021 at 3:01am
Thanks,

and yes, its an X570 Taichi rev 1 board that I purchased in October 2019

I tweeked the previous 1.21 version with a manual OC to hit those boost speeds. I'm not really a fan of software OC tools or apps I just tend to edit the BIOS. They menus and layout for the 4.60 Bios are completely different tho.

I have guests over right now but I'll post some BIOS screenshots tomorrow. Maybe I'm getting old but this is the first time in 20 years of building computers that I can't get the CPU to react like I want it to :p

Thanks for the quick reply !
Back to Top
Newrockuser View Drop Down
Newbie
Newbie
Avatar

Joined: 26 Sep 2019
Location: Belgium
Status: Offline
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote Newrockuser Quote  Post ReplyReply Direct Link To This Post Posted: 15 Sep 2021 at 1:41pm
Update.

Southbridge fan decided to start making angle grinder sounds on cold tarts so haven't done much testing, luckily Asrock customer support is sending me a new one which hopefully should be here today.

So:
X570 Taichi Rev 1
Bios 4.60
Ryzen 3700x

Previously boost speeds 4125 Mhz on all cores in cinebench 20
Current boost speed 4000 Mhz on all cores

Previously Peeks in boost speed upto 4550 Mhz
Current boost speed peeks 4350 Mhz

Previous voltage peeks 1.431 V
Current peeks 1.431V

Previous voltage average 1.37V
Current voltage average 1.30V

Previous CPU/SB temps max 74C/78C
Current CPU/SB temps max 70C/78C







Best results so far PBO (scoring 4370 Cinebench 20)
Playing Around with the PBO overdrive scaler did not really do much, Nor did playing around with the Max CPU boost clock rate.
The load line calibrations should be set to 3 on auto however manually setting both to 3 slightly lowered the bench marking scores.

I can achieve a steady 4.2 Ghz on all cores with a fixed voltage of 1.35V but I'm not really interested in running a fixed OC.

Is this bios just clocking worse than older versions ?
Back to Top
Newrockuser View Drop Down
Newbie
Newbie
Avatar

Joined: 26 Sep 2019
Location: Belgium
Status: Offline
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote Newrockuser Quote  Post ReplyReply Direct Link To This Post Posted: 15 Sep 2021 at 1:48pm
Ah Images failed, this should fix it.


Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.047 seconds.