ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Terrrrrrible audio on B550m :(
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Terrrrrrible audio on B550m :(

 Post Reply Post Reply
Author
Message Reverse Sort Order
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 9218
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Topic: Terrrrrrible audio on B550m :(
    Posted: 16 Sep 2021 at 12:11pm
Thanks for the update and fix info
Back to Top
a13antichrist View Drop Down
Newbie
Newbie
Avatar

Joined: 24 May 2018
Location: Amsterdam, NL
Status: Offline
Points: 41
Post Options Post Options   Thanks (0) Thanks(0)   Quote a13antichrist Quote  Post ReplyReply Direct Link To This Post Posted: 16 Sep 2021 at 7:13am
So I figured it out.
Windows 10 sometimes defaults Bluetooth to 'Hands-free' profile unless you tell it otherwise (is fine on both my Dell laptops, go figure..). Right-click on the speaker icon in taskbar, go to Sounds, Playback tab. Find the bluetooth device you need and switch the profile to Stereo instead of Hands-free. Set this as the default device too, if that's suitable for you.
R9 5950x | Asrock B550M Steel Legend | 64Gb 3600Mhz | RTX 3080
R5 5600x | Asus X470i | 32Gb | RX6800
R3 2200G | ASRock Fatal1ty AB350 ITX

2x Dell 7*70 | QNAP @24Tb | Mikrotik, TP-Link, Asus
Back to Top
a13antichrist View Drop Down
Newbie
Newbie
Avatar

Joined: 24 May 2018
Location: Amsterdam, NL
Status: Offline
Points: 41
Post Options Post Options   Thanks (0) Thanks(0)   Quote a13antichrist Quote  Post ReplyReply Direct Link To This Post Posted: 15 Sep 2021 at 9:03am
Hi friends, Hope someone can help... I'm trying to use bluetooth speakers, rather than a direct line output. Have a number of different speakers and they all have the same output.. also bluetooth headphones rather than speakers.. the same.
Have even bought additional Bluetooth adaptors and a Wifi/Bluetooth5.0 combo with a large antenna but no change.

The audio from any bluetooth device with any dongle is:
- Scratchy
- distorted
- sometimes muffled

Using an RDP connection from my laptop the sound is clean & clear (from laptop speakers). But processing sound from the B550m.

To note:
- THe distance to the speakers is about 6ft. Shouldn't be too much and also one of the Bluetooth dongles has an extra big antenna supposed to be for enhanced Bluetooth gain.
- I'm using USB 2.0 port because that's what's on the top of my case (O11D Mini) while the 3.0s are around the back facing away from me. However I used bluetooth with USB 2.0 before UBS 3.0 existed and didn't have these issues soo..
- have verified all speakers on other computers and no problems at all there.

I did check the drivers and installed the Realtek HD Audio package. It wasn't installed previously, just "HD Audio Device" but now I have the 'Realtek(Pro) Audio' shown. However sound remains identical (i.e. bad).

Yes I need to plug the speakers directly into the rear audio ports to confirm the issue only affects bluetooth. When I find a 3.5-3.5 jack cable I'll test that. It does play just fine over HDMI audio through the TV though.

Ideas?
R9 5950x | Asrock B550M Steel Legend | 64Gb 3600Mhz | RTX 3080
R5 5600x | Asus X470i | 32Gb | RX6800
R3 2200G | ASRock Fatal1ty AB350 ITX

2x Dell 7*70 | QNAP @24Tb | Mikrotik, TP-Link, Asus
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.047 seconds.