ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Windows 11 requirements
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Windows 11 requirements

 Post Reply Post Reply
Author
Message
Lodde View Drop Down
Newbie
Newbie


Joined: 06 Oct 2021
Location: earth
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lodde Quote  Post ReplyReply Direct Link To This Post Topic: Windows 11 requirements
    Posted: 06 Oct 2021 at 6:06pm
Hello.

I have few questions about Windows 11 and settings. I have 3700x, 2080rtx and x570 Extreme4 motherboard. I downloaded and run a program called "WhyNotWin11".
I have trouble with Secure Booth. I have succesfully changed options in UEFI, but "WhyNotWin11" says Secure Boot is not on/detected. Actually i did nothing but copy and pasted this to cmd to change value: ?œbcdedit /set ?œ{current}??bootmenupolicy legacy?? Now, on UEFI its says secure boot is enabled but on "WhyNotWin11" says it's not.

Then legacy boot. There are two options in uefi, "PXE OpROM Policy" and "Storage OpROM Policy". Which, or should i enable them both to get Legacy boot?

My current OS is Win10.
Back to Top
MadScientist View Drop Down
Groupie
Groupie


Joined: 17 Aug 2020
Location: TN
Status: Offline
Points: 363
Post Options Post Options   Thanks (0) Thanks(0)   Quote MadScientist Quote  Post ReplyReply Direct Link To This Post Posted: 07 Oct 2021 at 9:06am
If you have not already done so then flash the bios to the latest V3.80. Leave the bios at its default settings. This bios version enables AMD CPU fTPM in BIOS default.
Back to Top
Lodde View Drop Down
Newbie
Newbie


Joined: 06 Oct 2021
Location: earth
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lodde Quote  Post ReplyReply Direct Link To This Post Posted: 07 Oct 2021 at 2:47pm
My AMD CPU fTPM is already enabled.
Back to Top
Dan View Drop Down
Newbie
Newbie
Avatar

Joined: 28 Sep 2015
Location: Virginia USA
Status: Offline
Points: 92
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dan Quote  Post ReplyReply Direct Link To This Post Posted: 07 Oct 2021 at 8:33pm
Secure Boot cannot be enabled when Legacy boot is enabled. Disable Legacy boot first, and then enable Secure Boot.

Also, as suggested, if you haven't done so, update the BIOS to latest, even if ftpm is already enabled. You need latest update to make all this work.

You have to have UEFI compatible boot to make Secure Boot work. If your boot drive is MBR, you can convert it to GPT by using Easus Partition Manager.

I went through all this the other day myself.

Dan
Back to Top
BerndGaykema View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Nov 2019
Location: Netherlands
Status: Offline
Points: 124
Post Options Post Options   Thanks (0) Thanks(0)   Quote BerndGaykema Quote  Post ReplyReply Direct Link To This Post Posted: 08 Oct 2021 at 3:14am
I have the same issues.
I have upgraded my BIOS to the latest (beta) version available for the X570 Creator: P3.54
I converted all my drives, including the boot drive, to GPT (using Minitool Partition Wizard).
I activated Trusted Computing.
I set AMD fTPM switch to AMD CPU fTPM.
Secure Boot is still DISABLED (under tab Security).
CSM is still ENABLED (under tab Boot)

In this setting Win10 is booting fine.
The sanity tool from Microsoft shows 100% compatibility, so I can install Win11.
I am surprised, as Secure Boot is not active .....
X570 Creator, Ryzen 7 3800X, Corsair Vengeance LPX 2x16GB 3200 CMK32GX4M, Kingston NVMe A2000 500GB (OS), 1000GB (Data).
Back to Top
Dan View Drop Down
Newbie
Newbie
Avatar

Joined: 28 Sep 2015
Location: Virginia USA
Status: Offline
Points: 92
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dan Quote  Post ReplyReply Direct Link To This Post Posted: 08 Oct 2021 at 8:12am
Disable CSM, reboot the BIOS
Back in BIOS Enable Secure Boot
Reboot the BIOS
Back in BIOS, check whether Secure Boot is still enabled (it should be).
Worked for me.

Dan
Back to Top
BerndGaykema View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Nov 2019
Location: Netherlands
Status: Offline
Points: 124
Post Options Post Options   Thanks (0) Thanks(0)   Quote BerndGaykema Quote  Post ReplyReply Direct Link To This Post Posted: 11 Oct 2021 at 2:28am
Windows 11 could be installed without any problems with the BIOS settings as described above in my previous post.

I now disabled CSM, reboot and enabled Secure Boot in Standard mode.
Win 11 is now booting as well.

But certain things changes in the BIOS.
First, the PC is now booting from my other monitor.
Secondly, I have no boot drives visible, only Windows Boot Manager ( ).
Between the brackets my SSD which carries the OS is visible). No boot from USB or DVD possible anymore.
X570 Creator, Ryzen 7 3800X, Corsair Vengeance LPX 2x16GB 3200 CMK32GX4M, Kingston NVMe A2000 500GB (OS), 1000GB (Data).
Back to Top
Dan View Drop Down
Newbie
Newbie
Avatar

Joined: 28 Sep 2015
Location: Virginia USA
Status: Offline
Points: 92
Post Options Post Options   Thanks (0) Thanks(0)   Quote Dan Quote  Post ReplyReply Direct Link To This Post Posted: 11 Oct 2021 at 9:00pm
Have you checked the settings for multiple monitors? That is, right click the desktop, and select Display settings. In the options screen there, are options for multiple displays. Maybe something there can help fix the problem with the monitor.

I've not had a problem in BIOS not showing options for booting with drives other than by using Windows Boot Manager (USB drive or CD/DVD drive). I have no information on how to fix this situation. Maybe do a Google search to find possible solution. Just a thought.

Dan
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.063 seconds.