ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Problem with B450M new build
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Problem with B450M new build

 Post Reply Post Reply
Author
Message
Paul C View Drop Down
Newbie
Newbie


Joined: 09 Jan 2022
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paul C Quote  Post ReplyReply Direct Link To This Post Topic: Problem with B450M new build
    Posted: 09 Jan 2022 at 11:57pm
Hi all,
My cousins lad has decided to build his own PC. I've helped him put it together as I've knocked up a few of my own over the years (though it's been a while to be fair) but we couldn't get it to boot.

Took everything back out and wired it bare minimum - just 24 and 8 pin ATX, the power switch from the case, and HDMI out but it still won't post. Fans will come on for about 5 seconds, then stop, then have another go about 10 seconds later, but still nothing. I don't have a BIOS speaker to see whether that will give me any clue but do have one on the way from eBay.

I've tried the things I know:

    RAM seated properly, trying it in different slots and just the one.
    Reinserted CPU and checked for for a bent or broken pin.
    Graphics through both the card he's got (RTX 2060) and integrated, which the CPU does have.
    Clearing the CMOS.

My fear is there's some level of incompatibility with the RAM or CPU. CPU is on the QVL for the board but not the RAM. Also note there's no QVL for RAM in conjunction with Cezanne core processors.

Relevant parts of system as follows:

    ASRock B450M Pro4 AM4 M-ATX
    AMD Ryzen 7 5700G
    Crucial Ballistix BL2K8G32C16U4B 3200 MHz, DDR4
    Gigabyte GeForce RTX 2060 D6 6GB V2
    Samsung 970 EVO Plus 2 TB PCIe NVMe M.2 (2280)
    Corsair RM750x


Many thanks in advance for any help you guys can provide.
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 10368
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2022 at 1:03am
What BIOS version is the board running? (should be on a white sticker on the BIOS
ROM chip itself)

It sounds like it may need an update to support the 5700g.
Back to Top
Paul C View Drop Down
Newbie
Newbie


Joined: 09 Jan 2022
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paul C Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2022 at 1:38am
Thanks for the reply.

I thought of that beforehand and was going to put it in my original post, but can't see any label on any chip on the board.
Back to Top
Paul C View Drop Down
Newbie
Newbie


Joined: 09 Jan 2022
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paul C Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2022 at 3:01am
Sorry maculars not what they used to be. Bios version is 4.20. According to the update list Ryzen 5000 series support was added in 4.60, so it looks like your right.

Is the only option for updating the BIOS to get ahold of another AMD chip so it will boot?


Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 10368
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2022 at 7:02am
Aside from taking the board in somewhere to get it done for you, I am afraid so.
Good luck and make sure you check the BIOS update instructions carefully before
updating.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.062 seconds.