ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Ryzen 5000 support on x370
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Ryzen 5000 support on x370

 Post Reply Post Reply
Author
Message
Harleyevo View Drop Down
Newbie
Newbie


Joined: 03 May 2018
Location: USA
Status: Offline
Points: 71
Post Options Post Options   Thanks (0) Thanks(0)   Quote Harleyevo Quote  Post ReplyReply Direct Link To This Post Topic: Ryzen 5000 support on x370
    Posted: 15 Jan 2022 at 6:31am
Now that the ASRock X370 Pro4 has Ryzen 5000 support, how long will it be before this percolates down to the other x370 boards.

I'm looking for support for the X370 Gaming x.
Back to Top
meltdowner View Drop Down
Newbie
Newbie
Avatar

Joined: 27 Dec 2021
Location: NYC
Status: Offline
Points: 200
Post Options Post Options   Thanks (0) Thanks(0)   Quote meltdowner Quote  Post ReplyReply Direct Link To This Post Posted: 16 Jan 2022 at 9:28am
Wondering the same.
Back to Top
Harleyevo View Drop Down
Newbie
Newbie


Joined: 03 May 2018
Location: USA
Status: Offline
Points: 71
Post Options Post Options   Thanks (0) Thanks(0)   Quote Harleyevo Quote  Post ReplyReply Direct Link To This Post Posted: 14 Feb 2022 at 2:48am

So according to the interwebs there is a 7.00 bridge Bios and a 7.03 however all the links goto the Mobo page where only 6.00 is available.

going to https://asrock.com/support/index.asp?cat=bBIOS

From the Page:

Fatal1ty X370 Gaming X     7.00     2/8/2022     Bridge BIOS for 7.03
*This BIOS doesn't support Bristol Ridge CPU, do NOT update this BIOS if Bristol Ridge CPU is being used.
     Download

shows me that there is a 7.00 as a bridge for 7.03

but nada the download links back to the Mobo Page for 6.00

So ASROCK where is it!
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 12033
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 14 Feb 2022 at 2:57am
Scroll all the way down, under "Beta BIOS".
Back to Top
NeoTheFox View Drop Down
Newbie
Newbie
Avatar

Joined: 02 Feb 2018
Location: Moscow
Status: Offline
Points: 52
Post Options Post Options   Thanks (1) Thanks(1)   Quote NeoTheFox Quote  Post ReplyReply Direct Link To This Post Posted: 16 Feb 2022 at 4:37pm
I installed 5600x on my Fatal1ty Gaming X a few days ago, it's been working great. There is a small bug that makes my additional SATA controller skip its init during boot and then the disk never appears in the OS, but a reboot solves it.
Pretty happy with the performance
Back to Top
kerberos_20 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 06 Dec 2017
Location: czech republic
Status: Offline
Points: 2022
Post Options Post Options   Thanks (0) Thanks(0)   Quote kerberos_20 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Feb 2022 at 6:25pm
Originally posted by NeoTheFox NeoTheFox wrote:

I installed 5600x on my Fatal1ty Gaming X a few days ago, it's been working great. There is a small bug that makes my additional SATA controller skip its init during boot and then the disk never appears in the OS, but a reboot solves it.
Pretty happy with the performance

its a beta bios, you can provide feedback here, so bugs can be fixed in next bios update
Back to Top
spf48 View Drop Down
Newbie
Newbie


Joined: 22 Feb 2022
Location: United States
Status: Offline
Points: 45
Post Options Post Options   Thanks (0) Thanks(0)   Quote spf48 Quote  Post ReplyReply Direct Link To This Post Posted: 22 Feb 2022 at 5:50am
I've been trying to update my killersli/ac bios to the beta bridge bios, but my motherboard says it can't detect the file image after I extract the file from the asrock website to a flash stick.
Back to Top
kerberos_20 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 06 Dec 2017
Location: czech republic
Status: Offline
Points: 2022
Post Options Post Options   Thanks (0) Thanks(0)   Quote kerberos_20 Quote  Post ReplyReply Direct Link To This Post Posted: 22 Feb 2022 at 6:26am
Originally posted by spf48 spf48 wrote:

I've been trying to update my killersli/ac bios to the beta bridge bios, but my motherboard says it can't detect the file image after I extract the file from the asrock website to a flash stick.

which would suggest that youre downloading bios for some another mainboard or that flash stick is not working

some older mainboards had some issues with some flash drives
try to reformat that stick with 4kB block size
Back to Top
spf48 View Drop Down
Newbie
Newbie


Joined: 22 Feb 2022
Location: United States
Status: Offline
Points: 45
Post Options Post Options   Thanks (0) Thanks(0)   Quote spf48 Quote  Post ReplyReply Direct Link To This Post Posted: 28 Feb 2022 at 5:23am
The weird part is that the same drive flashes to the 3.5 and 4.6 just fine. With the same process as I did for the 7.0 bios.
Back to Top
spf48 View Drop Down
Newbie
Newbie


Joined: 22 Feb 2022
Location: United States
Status: Offline
Points: 45
Post Options Post Options   Thanks (0) Thanks(0)   Quote spf48 Quote  Post ReplyReply Direct Link To This Post Posted: 28 Feb 2022 at 5:35am
It's also weird because the motherboard briefly shows the 7.00killerac file on the screen before stating that it can't detect the image.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.047 seconds.