ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Asrock B660 Steel Legend Default XMP Not stable.
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Asrock B660 Steel Legend Default XMP Not stable.

 Post Reply Post Reply
Author
Message
Bluegap View Drop Down
Newbie
Newbie


Joined: 17 Sep 2017
Status: Offline
Points: 26
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bluegap Quote  Post ReplyReply Direct Link To This Post Topic: Asrock B660 Steel Legend Default XMP Not stable.
    Posted: 01 Jun 2022 at 6:09pm
Hi, I recently bought a B660 Steel Legend with Intel i5 12600k and installed 4 sticks of Kingston HyperX RGB ( KHX3200C16D4/8GX ).
There are 2 XMP profiles I can choose from the memory, when I set it to 3200 profile it will boot into the OS (Windows10), but is unstable random program crash and sometime BSOD. However It run smoothly with only 2 sticks or 4 sticks with 3000 profile which is I use right now.
I know that the memory currently is not in QVL, is there any workarounds to make it stable with 4 sticks at 3200 and would be happier if it can be OC'ed beyond that.
Things that I've done with no sign of stabilize:
- Increase Memory voltage up to 1.4 Volts
- Increase SA voltage up to 1.4 Volts
- increase VDD up to 1.3 Volts.

   
Back to Top
threadzipper1957 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 05 Mar 2022
Status: Offline
Points: 6040
Post Options Post Options   Thanks (0) Thanks(0)   Quote threadzipper1957 Quote  Post ReplyReply Direct Link To This Post Posted: 26 Jul 2022 at 11:12pm
I think it would be best to use the support form, this way ASRock has more info on the hardware, and BIOS version, and can help
https://event.asrock.com/tsd.asp
When using gmail, check your spam folder for replies.
I see that you ar using 2 kits, you should download thaipoon burner, it can readout the SPD chip, on the memory module.
Besides Samsung and Crucial, the rest are assemblers, they buy PCB's and chips, but due to a chip shortage of DDR4 memory chips, since introduction, they use any chip they can lay their hands on, and as long as the timing and speed are the same, they keep reusing the partnumber.
I have seen people buying 2 kits, one came with Micron chips, the other with Hynix, and the partnumber was the same, I even see that sometimes not only the brand of the chips differs, but also the size, and still use the same partnumber.
XMP is a set of vallues that is SUPPOSED to work on all existing combinations, of CPU, Chipset, and MOBO, and is far from optimal, and is also not guaranteed.
Here is how it tried it
Before changing settings, always load default settings (f9) and save with f10
1. don't use XMP, just set the DRAM speed to 3200, and save
2.use the 3000MHz XMP, but manually set the DRAM speed to 3200, maybe the timings work better.
3. use a FAT formatted USB stick, go into BIOS, and go to the DRAM configuration
Somehwere you should see the different timings.
Press f12 to make a BIOS screenshot, and print this
You will see all kinds of names and numbers, and this is important, there is a primary and secondary timing
tCL, tRCD, tRP, and tRAS belong to the primary timing, tRc, tRFC1/2/4 and the other are secondary timings
in BIOS you will see those values like tRFC, tRFC2, tRFC4, and if your smart, you also make a screenshot of the secondary settings, only value that doesn;t exist is tCCD_L
when using XMP, only Primary settings are taken over from XMP, Secondary settings usually stay on auto and the values do not match the info from the SPD chip.
You can try changing these manually.
But, don't forget, when making changes, always first reset to default.
And of course you can make screenshots.
When the kits, you have, have different chips, go for Patriot Viper, I have very good results, it always works

Kind Regards
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.109 seconds.