ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - ASRock B550M-ITX/ac No bios, no signal
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

ASRock B550M-ITX/ac No bios, no signal

 Post Reply Post Reply
Author
Message
Tingelponken View Drop Down
Newbie
Newbie
Avatar

Joined: 22 Sep 2022
Location: Sweden
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tingelponken Quote  Post ReplyReply Direct Link To This Post Topic: ASRock B550M-ITX/ac No bios, no signal
    Posted: 22 Sep 2022 at 3:10pm
Hi there, just built a new pc from scratch, but i just get no signal on my monitor and no BIOS comes up.

My Setup is:

Motherboard: ASrock B550M-ITX/ac

CPU: AMD Ryzen 5 5500

GPU: Gigabyte GeForce GTX 1650

SSD: Samsung 980 M.2

RAM: Corsair 2x8gb 3200Mhz

450w power supply.

As i said nothing shows up on my screen but the fans and lights all start in the computer.

Things ive tried:

Removubg the cmos battery 5 mins,

Removed the gpu and put hdmi in motherboard,

Tested ram 1 by 1

Nothings happening and i dont really know anymore, the cpu is supported for the motherboard according to asrocks website i dont think it needs a bios opdate maybe?

I'd appreciate any help i can get.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.109 seconds.