ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X670E PRO RS Graphics card problems
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X670E PRO RS Graphics card problems

 Post Reply Post Reply
Author
Message
cmbrodman View Drop Down
Newbie
Newbie
Avatar

Joined: 11 Nov 2022
Location: Somewhere
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote cmbrodman Quote  Post ReplyReply Direct Link To This Post Topic: X670E PRO RS Graphics card problems
    Posted: 11 Nov 2022 at 12:06pm
Hi, I have an X670E pro rs mb paired with a ryzen 7900x and 32gb (16x2) trident z5 neo ddr5-6000 and I?m having trouble getting my graphics card to work. It is an Asus ROG Strix RTX2080ti. It is not being detected whatsoever. I have reseated the gpu, cpu and ram and still nothing. There?s plenty of power (1000w psu). The card does work in another computer just fine and I put a different graphics card into the x670 and it also works. Any ideas on whats going on here would be appreciated- thanks
Back to Top
bjlockie View Drop Down
Senior Member
Senior Member


Joined: 17 Nov 2015
Status: Offline
Points: 1274
Post Options Post Options   Thanks (0) Thanks(0)   Quote bjlockie Quote  Post ReplyReply Direct Link To This Post Posted: 11 Nov 2022 at 1:25pm
Check that the video cable is plugged in to the card and not the motherboard.
That was my problem.
ASRock B450M Pro4
16 GB DDR4, 500 watt PS, AMD Ryzen-5 5600, NVidia GTX-1050, 5.70 BIOS
Back to Top
cmbrodman View Drop Down
Newbie
Newbie
Avatar

Joined: 11 Nov 2022
Location: Somewhere
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote cmbrodman Quote  Post ReplyReply Direct Link To This Post Posted: 11 Nov 2022 at 1:29pm
The cable is a known good cable- it is being used on that same graphics card in a different pc at the moment.
Back to Top
bjlockie View Drop Down
Senior Member
Senior Member


Joined: 17 Nov 2015
Status: Offline
Points: 1274
Post Options Post Options   Thanks (0) Thanks(0)   Quote bjlockie Quote  Post ReplyReply Direct Link To This Post Posted: 12 Nov 2022 at 3:49am
Not the cable, the port on the motherboard AND video card.
There are at least 2 places to plug it in.
ASRock B450M Pro4
16 GB DDR4, 500 watt PS, AMD Ryzen-5 5600, NVidia GTX-1050, 5.70 BIOS
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.047 seconds.