ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - problem enabling tpm on x399 taichi
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

problem enabling tpm on x399 taichi

 Post Reply Post Reply
Author
Message
wildbill View Drop Down
Newbie
Newbie


Joined: 10 May 2019
Location: Texas
Status: Offline
Points: 68
Post Options Post Options   Thanks (0) Thanks(0)   Quote wildbill Quote  Post ReplyReply Direct Link To This Post Topic: problem enabling tpm on x399 taichi
    Posted: 14 Nov 2022 at 10:09am
CPU: Threadripper 2950x
MB: x399 Taichi
Bios: P3.50
RAM: 128gb

Just tried to enable TPM via the AMD fTPM and Secure Boot ENABLED and could not find my boot device upon Save and Exit.

What am I missing?
Should I have cleared all Secure Boot keys?

When I went back to UEFI defaults, I was then able to boot Win10 again.

Yes, all this is to try to put Win11 on my system.

Thanks in Advance
Bill W
Back to Top
SerchTech View Drop Down
Groupie
Groupie
Avatar

Joined: 16 Oct 2022
Location: Spain
Status: Offline
Points: 475
Post Options Post Options   Thanks (0) Thanks(0)   Quote SerchTech Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2022 at 9:29pm
Hi Bill



Any reason not to update your old 3.50 BIOS version to 3.90 or 3.92?

Did you tested?


Kind regards
X399 Taichi | TR 2950X | 64GB HyperX 3200Mhz | 2 x RTX 3060
Back to Top
wildbill View Drop Down
Newbie
Newbie


Joined: 10 May 2019
Location: Texas
Status: Offline
Points: 68
Post Options Post Options   Thanks (0) Thanks(0)   Quote wildbill Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2022 at 9:36pm
I have not updated the bios due to fear of "bricking" my system. 8-)

Back to Top
SerchTech View Drop Down
Groupie
Groupie
Avatar

Joined: 16 Oct 2022
Location: Spain
Status: Offline
Points: 475
Post Options Post Options   Thanks (0) Thanks(0)   Quote SerchTech Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2022 at 10:55pm
Following the steps carefully to upgrade BIOS recommended by ASRock you shouldn't be worried.

It is very difficult to know the source of the problem if latest stable BIOS version is not installed, in this case 3.90

;-)
X399 Taichi | TR 2950X | 64GB HyperX 3200Mhz | 2 x RTX 3060
Back to Top
wildbill View Drop Down
Newbie
Newbie


Joined: 10 May 2019
Location: Texas
Status: Offline
Points: 68
Post Options Post Options   Thanks (1) Thanks(1)   Quote wildbill Quote  Post ReplyReply Direct Link To This Post Posted: 15 Nov 2022 at 5:16am
Fixed the issue. And probably didn't need to update the BIOS but it is done.

The issue is that the disk with Win10 was installed with MBR not GPT. Secure boot, from what I found, will only boot GPT. SO, I had to convert which worked beautifully via MBR2GPT.

After that, I was able to select SECURE BOOT in the UEFI, and was able to find the system disk and boot.

Now I am able to install WIN11

Bill W
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.125 seconds.