ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X570 gaming 4 Ryzen 9 won't boot
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X570 gaming 4 Ryzen 9 won't boot

 Post Reply Post Reply
Author
Message
rockys View Drop Down
Newbie
Newbie


Joined: 29 Jul 2018
Status: Offline
Points: 58
Post Options Post Options   Thanks (0) Thanks(0)   Quote rockys Quote  Post ReplyReply Direct Link To This Post Topic: X570 gaming 4 Ryzen 9 won't boot
    Posted: 20 Nov 2022 at 4:35am
I have been running a Ryzen 7 2700 CPU for a couple of years and wanted to install a Ryzen 9 5900x. I updated the BIOS and the chipset drivers but the PC won't boot with the new CPU. The CPU and RAM lights on the motherboard stay on and then about every 20 seconds it tries to boot again.

Since the BIOS is updated is there something else I need to do?
Back to Top
SirCarcass View Drop Down
Newbie
Newbie


Joined: 02 Dec 2022
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote SirCarcass Quote  Post ReplyReply Direct Link To This Post Posted: 04 Dec 2022 at 3:59am
Did you ever get this solved? I'm having the same issue with a 5700X.

Did you update the BIOS using the EFI method (and not Instant Flash)?
Back to Top
rockys View Drop Down
Newbie
Newbie


Joined: 29 Jul 2018
Status: Offline
Points: 58
Post Options Post Options   Thanks (0) Thanks(0)   Quote rockys Quote  Post ReplyReply Direct Link To This Post Posted: 04 Dec 2022 at 5:00am
I never got it resolved because ASRock support told me I needed to send the board in to them to get the BIOS updated. I decided to buy another MOBO instead of sending the old one in and paying shipping both directions.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.094 seconds.