ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X570 taichi broken£
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X570 taichi broken£

 Post Reply Post Reply
Author
Message
RoseBusch0608 View Drop Down
Newbie
Newbie
Avatar

Joined: 17 Mar 2023
Location: Michigan
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote RoseBusch0608 Quote  Post ReplyReply Direct Link To This Post Topic: X570 taichi broken£
    Posted: 17 Mar 2023 at 5:23am
My computer randomly shut itself off and won?t turn back on but the motherboard LEDs are lit and idk what to do. I unplugged and reply ffed the cord going to my power button but nothing worked still. It makes a single click sound when you push the power button as if it?s going to turn on but then it doesn?t. Can anyone help me troubleshoot?
Back to Top
eccential View Drop Down
Senior Member
Senior Member
Avatar

Joined: 10 Oct 2022
Location: Nevada
Status: Online
Points: 2085
Post Options Post Options   Thanks (0) Thanks(0)   Quote eccential Quote  Post ReplyReply Direct Link To This Post Posted: 17 Mar 2023 at 5:49pm
I suspect power supply, but not enough info to be sure.
Many motherboards lit up something with just 5VSB, but that doesn't mean the power supply is working, since all the other rails (5V, 12V) need to work to actually power up the computer.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.070 seconds.