ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - B550 pro 4 installing win10 on RAID0 issues
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

B550 pro 4 installing win10 on RAID0 issues

 Post Reply Post Reply
Author
Message
chromecut View Drop Down
Newbie
Newbie


Joined: 11 May 2023
Location: phoenix az
Status: Offline
Points: 55
Post Options Post Options   Thanks (0) Thanks(0)   Quote chromecut Quote  Post ReplyReply Direct Link To This Post Topic: B550 pro 4 installing win10 on RAID0 issues
    Posted: 08 Jun 2023 at 3:48am
I cannot for the life of me get win10 to install on AMD raid 0
there are 3 different guides for B550 pro 4 each with small differences between them-it may be the processor and/or ram as I have a 3300x installed with some confusing bios updating instructions for that model adding to the mix-bios update page says for bios ver 1.70 to not upgrade this bios if using 3300x-does that mean if you are already on 1.70 then dont go beyond this version or does that mean if you have 3300x then dont upgrade TO version 1.7 so its ok to go beyond 1.7 and skip it?after all these issues Im on 1.4 now hopefully eliminating another troubleshooting step so here are the deets
during install for 2 980 pros they each show with 1 small part-(those parts are the raid meta data obtained from initializing disks within bios) and after successfully loading the amd raid drivers nvme cc raid in the proper order {bottom, raid, config} there is indeed a single disk but when selected win10 install hangs at 0%-(the single disk actually becomes available before the last driver(config)is loaded which is one of the instructions variations which says only 2 drivers are needed
both disks and arrays were deleted and then initialized prior to creating the array in bios-i tried it with read ahead/cache on and all off to same result
I figured I could wrap up the raid install inside of WIN10 by installing the drivers and raid management software to a fresh install and then cloning everything over but during the formating portion of the newly created array within windows hangs unresponsive requiring a forced reboot-I have tried clean, clean all, b550 pro 4 mobo uefi setup nvme sanitizer without initialization so I could try windows software raid and both drives now disapear, show as foreign, shows as bad disk,etc or goes offline when trying to format or clean using diskpart-I finally got one drive to take a clean all/W format but not the other-
confilcting instructions:one set says set csme to uefi only while another says disable csme completely, one set says set sata to raid and set nvme raid while another set says just set nvme raid if using only nvme
another set says choose both or ssd when creating the initial array while another says just select nvme
one set says to go to and set another different sata raid tab(the one with aggresive sata sleep)-so 2 different sata raid tabs and the nvme raid tab choice makes troubleshooting this silly stupid without clear instructions
and no these are not part of instructions differencing am4, x570,processors with amd radian graphics, etc which is super confusing as small criteria crosses over to 2 choices-right now Id like to get the other drive working normally again(no raid)and Im all done with AMD raid
things to mention with a question-so I have one drive in main m.2 slot and another in a single pcie m.2 adapter card in the top gpu slot with pcie 3.0 gpu in lower slot-those 2 slots are the only way minus a quad m.2 adapter card to get pcie 4.0 speeds as the bottom m.2 is pcie 3.0 x2 only
so whats unlear is the the top gpu slot and top m.2 slot are both driven by cpu lanes or is the m.2 slot handled by the pch? bios sees both drives as does windows but maybe the virtual disk being assembled doesnt like merging 2 different sources-also what should the bifurcation be? I thought x4x4x4x4 was for the x16 slot only for use with a 4 drive carrier but another forum said doing that shares the lanes to the other drives and the x8 x8 option is clearty intended for more bandwidth to gpu second slot if needed so what handles the gpu, upper and lower m.2 slots if I was to use all x16 for the top pcie slot?
so to date my asrock deskmini 310 is borked-(have no idea what could be wrong) and my deskmeet b660 does not get all x16 lanes from pcie slot and the b550 possibly having 2 trashed 980 pros and contacting tech support? good luck with that
Back to Top
threadzipper1957 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 05 Mar 2022
Status: Offline
Points: 9365
Post Options Post Options   Thanks (0) Thanks(0)   Quote threadzipper1957 Quote  Post ReplyReply Direct Link To This Post Posted: 22 Jun 2023 at 5:17pm
The Agesa code in 1.70 caused problems for some 3300X CPU, that is why there is a warning
All other BIOS versions should be fine.
Regarding RAID, there are several options,
1. Your disks cannot supprot RAID, mening the Array will be created, but the OS simply cannot install
2. hidden pertitions, this can be solved when You remove the raid, and use default BIOS settings, then boot from a Windows inbstalkl USB stick, and at the stage where language and keyboard layout start, press Shift-F10 to open a command prompt and start diskpart
You need know the commands
List disk
Select disk {disknumber}
When You give another list disk, it should show an asterisk in front of the selected drive
clean
once both M.2 are clean, You can exit, with exit, and shutdown the command prompt with Exit.
Then start a new RAID Array in BIOS, and of course enable NVME RAID.
When installing Windows, You can install the RAID drivers, and it should work
Kind Regards
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.172 seconds.