ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X670E Steel Legend
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X670E Steel Legend

 Post Reply Post Reply
Author
Message
Buligai View Drop Down
Newbie
Newbie


Joined: 08 Jul 2023
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote Buligai Quote  Post ReplyReply Direct Link To This Post Topic: X670E Steel Legend
    Posted: 08 Jul 2023 at 11:26pm
Hi guys I am looking forward to buy a motherboard from ASRock -> X670E Steel Legend model and I want to pair it with a memory kit from GSkill: F5-6000J3038F16GX2-TZ5N (This is a Trident Z5 Neo model and on GSkill page and on other motherboard manufacturers says it supports EXPO not XMP) and I was looking today on the memory QVL of ASRock X670E Steel Legend and it says it has XMP not EXPO and I am confused. Can someone confirm that this memory kit that I want to buy does support EXPO on this motherboard please? Thanks!
Back to Top
jhone432 View Drop Down
Newbie
Newbie
Avatar

Joined: 28 Aug 2023
Location: United States
Status: Offline
Points: 45
Post Options Post Options   Thanks (0) Thanks(0)   Quote jhone432 Quote  Post ReplyReply Direct Link To This Post Posted: 28 Aug 2023 at 5:44am
Originally posted by tyerllwendland512 tyerllwendland512 wrote:

Hey there! I understand your confusion regarding the compatibility of the memory kit with the ASRock X670E Steel Legend motherboard. To clarify, the ASRock motherboard supports https://resultadosdeltris.net/ rather than EXPO. However, it's worth noting that the GSkill Trident Z5 Neo model you mentioned is listed as supporting EXPO on the GSkill page and other motherboard manufacturers. It would be best to reach out to ASRock or GSkill directly for confirmation on whether this specific memory kit will work with the X670E Steel Legend motherboard. They should be able to provide you with accurate information. Good luck with your purchase!
SJHUR
Back to Top
luki99 View Drop Down
Newbie
Newbie


Joined: 02 Nov 2023
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote luki99 Quote  Post ReplyReply Direct Link To This Post Posted: 02 Nov 2023 at 10:49pm
I have a problem with these memories. The board sees the expo 6000 profile, but the system is unstable (bluescrean reset). It only works stably on 4800 in the 2 x 16 GB configuration. On one stick, 6000 is stable.
I also had a problem with running it in slots A2 and B2, it only works on B1 and B2
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.125 seconds.