ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Steel Legend X670E Can't detect M.2
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Steel Legend X670E Can't detect M.2

 Post Reply Post Reply
Author
Message
8bitcode View Drop Down
Newbie
Newbie


Joined: 22 Aug 2023
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote 8bitcode Quote  Post ReplyReply Direct Link To This Post Topic: Steel Legend X670E Can't detect M.2
    Posted: 22 Aug 2023 at 2:53am
Hello all, I have problems with a steel lengend x670e, when It arrives I didn't got any problem at all, it boot right and even played God of war for like 2 hours, then when I made a fresh system install the horror begins.

The first of all problems, suddenly it stops recognizing the m.2 drives.

I made an bios update, bios reset, change the ports , at the end the thing that worked was pop out the battery, disconnect from the wall and leave like that for 10 mins, it went to the system again...but, when I begin to install updates and drivers and needed to reboot again the m.2 problems, and sometimes don't even boot, it just stays at ASRock logo, or black screen until it redirects to bios.

I have a Ryzen 7 7800x3d 64 GB (2x32)
G skill 6000mhz modules
2tb 980 pro M.2
500gb 980 pro M.2 for the system
Gigabyte 6800xt gaming oc EVGA NEX750g PSU

Por the record I got this EVGA PSU like from 7 years ago, and before the steel legend I got an Aorus Elite AX b650 but I didn't even get it to boot because of many bios and dram problems, it can be the PSU, my old system got a b450 tomahawk max II and sometimes got the same problems of m.2 didn't detect the drives

I tested the ram modules with memtest86+ for like 18 hours and didn't get any problems

Help me guys I think a have a very bad luck with this build , two mobos in a row... And sorry for my english
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.281 seconds.