ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - B650M Pro RS WiFi - Worked...then didn't
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

B650M Pro RS WiFi - Worked...then didn't

 Post Reply Post Reply
Author
Message
calthaer View Drop Down
Newbie
Newbie


Joined: 07 Sep 2023
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote calthaer Quote  Post ReplyReply Direct Link To This Post Topic: B650M Pro RS WiFi - Worked...then didn't
    Posted: 07 Sep 2023 at 9:49am
Just put together the following system:
ASRock B650M Pro RS WiFi
AMD Ryzen 7 7700X
CORSAIR Vengeance 32GB (2 x 16GB) 288-Pin PC RAM DDR5 5600 (PC5 44800) x2 (64GB)
Corsair MP700 Gen5 NVME SSD M.2 2280 1TB PCI-Express 5.0 x4 3D TLC Internal Solid State Drive
DeepCool AK400 WH Performance CPU Cooler

And you know what? At first it worked. Got it to recognize all 64GB of the RAM (took a few minutes, as the manual suggested), booted from the DVD drive (left over from the previous build this was replacing), installed Windows 10, the ASRock auto-software update installed drivers...rebooted...everything looked good.

I remove the DVD from the drive, unplug the machine, and take it upstairs from the basement. Plug everything in and now it won't boot up.

The CPU and DRAM lights stay lit. I removed all the DRAM but one chip (sitting in the B2 slot, as the manual suggests) to enable faster boot. Cleared the CMOS - no dice. Saw several messages online suggesting that older versions of the BIOS has memory compatibility issues, so flashed it to 1.24. I'm able to get into the BIOS now, but the screen looks odd - red color, slightly corrupted text (have a pic, but don't see the editing features in this window to embed). But it functions - just won't actually boot.

I'm about to return this board - never had this much trouble with a build. Any suggestions?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.188 seconds.