ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X670E PG Lightning no post
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X670E PG Lightning no post

 Post Reply Post Reply
Author
Message
Thirdhero View Drop Down
Newbie
Newbie


Joined: 15 Sep 2023
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote Thirdhero Quote  Post ReplyReply Direct Link To This Post Topic: X670E PG Lightning no post
    Posted: 15 Sep 2023 at 4:30pm
So I just received my x670e PG Lightning and I installed it in my system with a 7900x and some Gskill flare X5 F5-6000J3636F16GX2-FX5
2 sticks of 32GB Expo memory. I am trying to start my PC fans come on full speed and Dram and CPU lights are on solid red.

I have reseated my CPU and reseated my ram and tried individual sticks installed according to the manual.

I only plugged in the 4+4 ATX12V1 connector the V2 is not connected as the manual mentioned it was optional.

Still cannot get it booted I checked, double and triple checked all the connections. I am honestly a bit stumped on what to do right now so any help would be appreciated

Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 8592
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 19 Sep 2023 at 6:33pm
Dear Thirdhero,
Thank you for the posting.

For this case, please kindly refer to the following suggestions to see if the system can post.
1. Please refer to the user manual on page 6 No.26 and page 35 to try clear CMOS.
User manual: https://download.asrock.com/Manual/X670E%20PG%20Lightning.pdf
2. Please install only one memory module on the slot B2.
3. Repeat step 2 and install the memory module in other slots and try.
4. Please make sure memory module is installed properly, we recommend using both hands to install the module firmly.
5. Please install only the CPU, CPU cooler, one memory module (slot B2) and keyboard on the system to check if the system can POST. (Remove other devices such as the USB devices and SSD)
6. Please re-plug the power supply cable.
7. Please reinstall the CPU to try. Also make sure the CPU socket is not pin bent.
8. If possible, please try with another CPU, memory module, and power supply.

Thank you

Yours truly,
ASRock TSD
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 22973
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 19 Sep 2023 at 7:15pm
Try powering up the system and leaving it powered up for 10mins or so. Sometimes
the first POST can take an insanely long time. It seems to be particularly common
with AM5.
Back to Top
rouki999 View Drop Down
Newbie
Newbie


Joined: 28 Nov 2022
Status: Offline
Points: 145
Post Options Post Options   Thanks (0) Thanks(0)   Quote rouki999 Quote  Post ReplyReply Direct Link To This Post Posted: 23 Sep 2023 at 12:53pm
I have the same issue with my X670E RS.

My System is a 7950x with 2x 32 GB Ram (F5-5600J3036D32GX2-TZ5RK).

The system is running fine and sometimes the BIOS is hanging in the POST.
It only helps to reset the BIOS!
After reset from the BIOS the system is booting again. Then you have to set your BIOS settings again.
If I switch to the XMP profile from the DRAM. It takes minutes to boot the first time with this settings. You don´t know is the BIOS hanging again or is it doing something. You have no screen or something else. Only the CPU and DRAM LED is red.

I think there big problems in the BIOS! I don´t know what the problem is, but I can say, I will not buy a Asrock Mainboard again.
The BIOS is one the worst in compare to the others supplier for AMD. It takes much longer to get a new stable BIOS version in compare to the others. Only the price is better, but in form of stability and fast support, then I will pay a couple of ??more for that.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.109 seconds.