Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - B660M Steel Legend - No mouse, no keyboard on POST
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

B660M Steel Legend - No mouse, no keyboard on POST

 Post Reply Post Reply
Xarick View Drop Down

Joined: 14 Oct 2023
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xarick Quote  Post ReplyReply Direct Link To This Post Topic: B660M Steel Legend - No mouse, no keyboard on POST
    Posted: 14 Oct 2023 at 4:01am

I registered to the forum because I'm stuck with a problem I can't solve on my own. I require some assistance.

A friend of mine has very recently acquired an ASRock B660M Steel Legend motherboard and asked me to configure the BIOS to have the LEDs for the mouse, keyboard and other USB devices to be turned off when the system is off.

However, I must have messed up somewhere inside the BIOS settings. The Mouse, Keyboard, and MB PCB RGB do turn off the LEDs when Windows is shut down, but still, some other devices connected via USB do keep up the LEDs on.

I went again in BIOS to mess with some more settings to see if I could have all the rest to be powered off when windows is shut down, and... got into a big problem.

The worst part now is that when I turn on the system, I have no keyboard nor mouse during the POST phase. I can't press DEL, nor F2 or F6, or anything to enter BIOS!

I tried the utility that restarts and enters UEFI mode automatically. It gets there, but since I got neither mouse or keyboard, I can't do anything but stare at the screen.

I tried removing the battery, waited 4 hours and insert it again, in hope that it would reset everything. And it seems that it did.

When I power on the system, I see that the keyboard and mouse are now lighted up during POST! But when the screen reaches ASRock logo with the hotkeys listed at the bottom right part, it gets stuck! Doesn't boot into windows, pressing F2 or DEL doesn't enter BIOS, nothing. I am forced to power off the system.

Next time it boots, I no longer have keyboard nor mouse lighted up, and now it's asking me to press F2 to set the system time and date. I can't! No keyboard! And worse, I couldn't even go into Windows. It kind of bricked!

At this point I tried several other things. Turned the system off, pressed the bios flashback at the back of the motherboard, nothing! Still asking me to press F2 to set the time right.

Finally, I resorted to using a jumper on the clear CMOS, and it no longer asks me to set time and date. What a relief it was! It boots into Windows! However, I'm still unable to enter BIOS. The keyboard and mouse continue to be powered off during POST.

I end up giving up at this point and came here on this forum, asking if anyone knows how to solve this situation. Note that I do have keyboard and mouse on Windows though, just not during POST. I wanted to solve this. Any help is appreciated.
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group

Joined: 16 May 2015
Location: Europe
Status: Online
Points: 22253
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 16 Oct 2023 at 2:57pm
If you have not already, try this:

Also make sure your keyboard and mouse are plugged into the top 2 USB ports on your
rear IO panel. These are typically the preferred ports for input devices. It isn't
essential under normal circumstances but when you are having an issue like this
it doesn't hurt to use the ports most likely to work.
Back to Top
Xarick View Drop Down

Joined: 14 Oct 2023
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xarick Quote  Post ReplyReply Direct Link To This Post Posted: 22 Oct 2023 at 6:22pm
Thanks for replying. I will retry those steps again, as soon as I can get my hands on an additional jumper. The one I used on his system was borrowed from my own, meaning I would be without a system for the hours needed for the Clear CMOS procedure. Probably later this week, my friend will have bought his own jumper to test.

Meanwhile, I have a bit more details to add that I missed in the initial post. Currently, while I still have no keyboard nor mouse during POST, the system can boot into Windows, however, the booting procedure is not without flaws. I explain:

- First, when powering on the system, it gets to the ASRock logo screen with the 'F' keys listed at the bottom right, but it hangs there. It doesn't advance past that screen into Windows. Looking at the motherboard Post Status Checker LEDs (PSC as referred as in the manual), I see a fixed red light indicating there's a dysfunctional VGA. Very strange in my opinion that it thinks there's an issue with the graphics card. It is a Sapphire Pulse RX 5600 XT by the way, but I don't think there's anything strange with it. It runs fine on another system. Unfortunately, the CPU is a Core i5 12400F, without integrated graphics and neither I or my friend have another graphics card to experiment with.

- Second, once pressing the reset button, or powering off then on the system, it finally boots into Windows: it goes past the ASRock logo screen, the 'F' keys disappear from being shown and an animating windows loading circumference takes place. The motherboard PSC LEDs become turned off after cycling red.

This got me thinking... was my previous Clear CMOS attempt a futile one? I remember it being able to power on the USB keyboard and mouse LEDs at least on the first boot but hanging on the ASRock logo during POST. A forced shut down of the system at that point would have reseted the BIOS settings to the previous configuration (the one which doesn't power the keyboard nor mouse). Am I right on this assessment?

What else could I try should my next Clear CMOS attempt fail in the same manner?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.109 seconds.