ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Not booting to BIOS. DRAM red light showing
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Not booting to BIOS. DRAM red light showing

 Post Reply Post Reply
Author
Message Reverse Sort Order
helpmee View Drop Down
Newbie
Newbie


Joined: 21 Oct 2023
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote helpmee Quote  Post ReplyReply Direct Link To This Post Topic: Not booting to BIOS. DRAM red light showing
    Posted: 21 Oct 2023 at 7:23pm
Hi all,

I am hoping someone can give me a hand as I've been struggling for a week with this. I have a new build PC and on start, I can not boot to the BIOS and there is a red light showing on the mobo. No other red lights are on.

Things I have tried:
- Bought new RAM and checked compliance to the mobo
- Used combinations of RAM single and dual across all slots
- Double checked the connections to PSU for MOBO

My build is as follows:
- ASRock Z790 Steel Legend WiFi Intel DDR5 PCIe 5.0 ATX Motherboard - LGA 1700
- Intel Core i7 14700K, S 1700, Raptor Lake Refresh, 20 Cores, 28 Threads, 5.6GHz Turbo, 33MB Cache, 125W, Retail 7QYCY
- CORSAIR VENGEANCE RGB DDR5 RAM 32GB (2x16GB) 7200MHz CL34 Intel XMP iCUE Compatible Computer Memory - Black (CMH32GX5M2X7200C34)
or the replacement:
-CORSAIR VENGEANCE RGB DDR5 RAM 32GB (2x16GB) 6000MHz CL36 Intel XMP iCUE Compatible Computer Memory - Black (CMH32GX5M2D6000C36)
- NVIDIA GeForce RTX 4070 Founders Edition 12GB GDDR6X Graphics Card 7QWNT

Is there anything I can do or try?

I am aware that I need to update BIOS to use the new CPU, but can't boot to bios currently. I've also tried HDMI and displayport connections to the MOBO and the GPU, to see if this was the issue.

No system beeps... but I may have not plugged a cable in correctly (although can't see where)
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.188 seconds.