ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - H97 Pro4 LAN Driver for Recovery Environment
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

H97 Pro4 LAN Driver for Recovery Environment

 Post Reply Post Reply
Author
Message
Datango View Drop Down
Newbie
Newbie


Joined: 18 Jun 2015
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Datango Quote  Post ReplyReply Direct Link To This Post Topic: H97 Pro4 LAN Driver for Recovery Environment
    Posted: 19 Jun 2015 at 7:39pm
This motherboard has been newly installed and it is required to load a network driver from a .INF file and map a network drive from within a recovery environment (Symantec Backup Exec).

The previous motherboard successfully loaded a WinVista 32 bit driver after which a network drive could successfully be mapped.

However, with this motherboard the drive mapping fails. It is suspected that this is because an incorrect driver has been loaded.

What is the correct driver to be used in this situation?

TIA


Edited by Datango - 19 Jun 2015 at 7:41pm
--
Datango
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 1:21am
Originally posted by Datango Datango wrote:

This motherboard has been newly installed and it is required to load a network driver from a .INF file and map a network drive from within a recovery environment (Symantec Backup Exec).

The previous motherboard successfully loaded a WinVista 32 bit driver after which a network drive could successfully be mapped.

However, with this motherboard the drive mapping fails. It is suspected that this is because an incorrect driver has been loaded.

What is the correct driver to be used in this situation?

TIA


I assume you are still using Vista 32bit with the H97 Pro board? Vista is not officially supported by this board, because the new H97 chipset does not support Vista.

Your board uses an Intel I218V network chip, which did not exist during the Vista era. The generic Vista network driver obviously does not work.

The best I can suggest for you are the Win 7 32bit drivers.

The Intel network driver provided for your board (Win 7 32bit version), the  Lan driver ver:19.0.27.0 can be found on your board's Win 7 32bit download page:

http://www.asrock.com/mb/Intel/H97%20Pro4/?cat=Download&os=Win7

The network drivers provided by Intel for the I218V can be found here:

https://downloadcenter.intel.com/product/71305/Intel-Ethernet-Connection-I218-V

You might need to download the Intel® Ethernet Connections CD on the above page, and find the basic driver package that includes the INF file. As Intel states, this file is huge and otherwise only the standard Windows driver installation program is provided.

The standard INF file installation program for your board can be found here, but that program simply installs the INF files for the board's Intel hardware, and does not contain any drivers:

http://www.asrock.com/mb/Intel/H97%20Pro4/?cat=Download&os=Win764





Back to Top
Datango View Drop Down
Newbie
Newbie


Joined: 18 Jun 2015
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Datango Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 9:03pm

 

Persec

Thanks for the response, but unfortunately the assumption that 32bit Windows Vista is being used is incorrect.

The requirement is to load a network driver from a .INF file from within the recovery environment to restore a previously backed up Windows 7 system stored on a NAS drive.

However to achieve this the recovery environment, which is a graphical interface but not full Windows, the previous motherboard?�s onboard network adapter used a Realtek PCIe GBE Family Controller with a WinVista 32bit driver.

The LAN drivers 19.0.27.0 and PROWin32 which you suggest each contain several .INF files

Prior to posting each of these had been tried without success. The recovery environment reported that the driver had been successfully loaded but attempts to map a network drive were unsuccessful and produced a ?�Path Not Found??error message.

The purpose of the post was to confirm which, if any, of the .INF files was appropriate for this situation.

It seems that what is required may not be achievable with the Intel network adapter, although I find this somewhat surprising.

 



Edited by Datango - 20 Jun 2015 at 9:04pm
--
Datango
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.102 seconds.