ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - (AM1H-ITX) Slow boot with SSD
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

(AM1H-ITX) Slow boot with SSD

 Post Reply Post Reply Page  12>
Author
Message
jamaster14 View Drop Down
Newbie
Newbie


Joined: 20 Jun 2015
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote jamaster14 Quote  Post ReplyReply Direct Link To This Post Topic: (AM1H-ITX) Slow boot with SSD
    Posted: 20 Jun 2015 at 2:23pm
I have 2 identical  builds using AM1H-ITX boards:

AM1H-ITX
AMD Athalon 5350
Samsung EVO 840 - 250 GB SSD
Corsair Vengence DDR3 1600 - 16 GB (2x 8 GB)
Windows 7 pro 64-bit

All drivers downloaded and installed off the website, device manager shows no issues.  ACHI enabled prior to windows install

Machine takes a long time to boot.  from power on to windows desktop is 35-45 seconds.  much longer then id expect from a SSD.  

Tried a fresh windows install on one of the builds, set boot to 'fast', didnt have any effect.

Checked to see if the drive was connected to a SATA II port, but according to the manual all 4 ports are SATA III

Not really sure where to start with this one.  any help would be greatly appreciated


Edited by jamaster14 - 20 Jun 2015 at 2:30pm
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 6783
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 2:57pm
Welcome to the forums Smile

How much of that 35-45 seconds is taken up by the Post process? I am assuming not much given you are concerned that boot times are too slow for a system booting from SSD.  

To test the performance of you SSDs you could use

AS SSD Benchmark and post up a screenshot of the results.

The Athlon 5350 is an awesome little low power CPU, I was sorely tempted to build an ITX system around one myself when they came out. What you do have to bare in mind though is that they are a low power solution and not designed for performance. My system with a Pentium G3258, 8gb (2x4gb) DDR3 1600 (@1400mhz) with a PNY optima 240gb SSD boots in about 20 - 30 seconds using fast boot so your numbers don't seem all that bad from where I sit. 

Bare in mind that post times can vary widely from one motherboard platform to the next depending on such things as chipset, number of features that need to be initialized at post etc. While 45 seconds is a little on the high side for an SSD based system it means very little if say 15 seconds of that is taken up by post.
Back to Top
jamaster14 View Drop Down
Newbie
Newbie


Joined: 20 Jun 2015
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote jamaster14 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 3:08pm
Thank you for the reply!

The post doesnt take very long.  maybe 4 or 5 seconds between the 2 screens.  most of it is the windows splash screen and the windows welcome/logon screen.  

I will run the bench marks using that utility and post up the results.

I do realize the trade off of low power/quiet build vs. performance, but this unusually long.  i was hoping for something more in the 15-25 second range.  its not the end of the world if the boot time is what it is, but id think it should be a bit faster.

anyhow, thanks for the input, ill post the screens up in a bit.
Back to Top
jamaster14 View Drop Down
Newbie
Newbie


Joined: 20 Jun 2015
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote jamaster14 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 3:26pm
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 6783
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 3:43pm
Those scores look fine for a raw drive bench. If memory serves Samsung Evo drives support RAPID mode that drastically improves performance in certain workloads. I am not certain if your drive supports it but its definitely worth checking out. 

I ran a quick comparison bench on my optima 240 for you:


Your drive is higher end than mine so performs a little better where it counts Smile
From your results you are right where you should be with an Evo, not at the top of the charts for that model but not under-performing at all either. 

In other words the drive is performing as it should so any additional boot time is coming from the rest of the system. Rapid (if applicable to your drive) will not help boot times by much, if any, but will help in certain workloads to provide a snappier response time on your SSD.

If your drive supports it and you install it, run the benchmark again and take a look at the difference Wink

[edit] I confused Readyboost (windows) with Rapid (samsung) sorry about that lol. All fixed.


Edited by Xaltar - 20 Jun 2015 at 3:53pm
Back to Top
jamaster14 View Drop Down
Newbie
Newbie


Joined: 20 Jun 2015
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote jamaster14 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 3:54pm
Thanks, it came with a CD, maybe that utility is on there.

is the driver im using ok?   ive seen other screens shots of evos using a different one then mine has listed?

Im tempted to use the asrock instant boot utility.  it works well, but it has some issues with running software on startup, this build is for an NESPC, so ideally it would boot right into the emulator, which it doesnt seem to do even though without instant boot i can get it to run on startup.


Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 6783
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 4:06pm
Perfect choice for a NESPC Thumbs Up

Here is the download page for your drive, download and install the latest "Magician Software" and keep the page bookmarked incase you experience performance degradation, in which case update to the latest firmware. I wouldn't update unless you have performance problems. Although looking at the firmware it does appear to improve performance with Magician so I guess its up to you if you want to try out the latest firmware.

How are you setting your startup apps with instant boot? 

(edit) OK so I just timed my boot from power on to desktop I clock in at 18 seconds in windows 8.1 which is known to boot faster than win7. 


Edited by Xaltar - 20 Jun 2015 at 4:17pm
Back to Top
jamaster14 View Drop Down
Newbie
Newbie


Joined: 20 Jun 2015
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote jamaster14 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 4:31pm
Yeah the build came out great... after modifying the case everything fit perfect and with a coat of new paint it looks like it rolled right out of the factory:

here are the photos of the project start to finish if you are interested:  https://s89.photobucket.com/user/jamaster14/library/NESPC%20Project?sort=3&page=1

And here are a couple of the finished product




I'll try that magician software, thanks for the link.

As far as startup, i tried a couple methods:

1)  added a key under ...\currentversion\run in the registry to get the context menu item in msconfig.  then checked it off.  it runs at startup with isntant boot disabled, but not instant boot

2)  I shelled windows, and had the system boot to hyperspin.exe (my emulation front end) instead of explorer.exe.  which works great booting normally, but when trying to run on instant boot, it never takes... instant boot will shut down, reboot, but then never shutdown the second time.  i guess it needs explorer to be able to run tis course?

Ideally, since its an NES PC id like it to boot into the front end as quick as possible.  if i can get the boot time in the 20 second range that would be great.  i can changed the windows splash screens and logon screens to nintendo stuff but 45 seconds still kind of kills the effect.  

If i can get instant boot to work, where it will power on and immedietly start up hyperspin, that would be the best case.  

thanks for the responses,if you have any other ideas on the best route to do this id love to hear it


Edited by jamaster14 - 20 Jun 2015 at 4:32pm
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 6783
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 4:43pm
That looks fantastic, great job Thumbs Up


Here is another NES conversion build I was looking at recently Smile
As for the startup problem I am at a loss, you have already done what I would have suggested. I don't suppose you have tried the idiot option of adding the emu to the startup menu?

As for boot speed, if you can get your hands on Windows 8.1 and give that a try it should cut down boot times. Instant boot seems to have an aversion to running startup apps....




Edited by Xaltar - 20 Jun 2015 at 4:44pm
Back to Top
jamaster14 View Drop Down
Newbie
Newbie


Joined: 20 Jun 2015
Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote jamaster14 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jun 2015 at 5:12pm
yeah startup menu didnt help.  but maybe there is antoher way, ill have to keep playing around with it.  

i think ill just run the magician thing and then just live with the 40 seconds or so.  if anyone else has any ideas on how to speed it up, im all ears. 

i could go windows 8, but the front end and emulation im running likes windows 7 better and that part takes precedence over boot time.  


Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.078 seconds.