Forum Home Forum Home > Technical Support > AMD and Intel Graphics Card
  New Posts New Posts RSS Feed - RX7900XT PG not recognized by Polychrome
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

RX7900XT PG not recognized by Polychrome

 Post Reply Post Reply
twentyone View Drop Down

Joined: 03 Mar 2024
Location: Germany
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote twentyone Quote  Post ReplyReply Direct Link To This Post Topic: RX7900XT PG not recognized by Polychrome
    Posted: 03 Mar 2024 at 10:10am
Okay so I know theres already several posts with this problem hoewever I tried all solutions within those posts and none of them worked.

The problem is fairly simply: My ASRock Radeon RX 7900 XT Phantom Gaming White OC ist not being recognized by any form of RGB Software (mainly Polychrome obviously).

This is the journey I had with the problem:

Starting up my PC with the Card for the first time the RGB worked fine with a basic RGB Color Fade. After trying to figure out how I can sync my AIO Pump, RAM and Fan ARGB (which Ive done with SignalRGB because Gigabyte RGB Fusion couldnt get the RAM) the GPU was still in the normal RGB Color Fade. So then I tried to figure out how to change that (SignalRGB didnt recognize the GPU).

First thing I did was Google and download a "random" Version of Polychrome which should be v.1.0.38. If I remember correctly the software went into an infinte loading screen "Scanning for Devices" so I went to Google again. I´ve then tried several other versions of Polychrome.
And yes, one of those is the one on the exact product page of my GPU
( which also didnt work.

However one time (I unfortunately dont know which version it was) the Software found my GPU with the RBG settings, but changing the color in the software then didnt change the color of my GPU so I uninstalled it again.

Also at some point in testing the GPU RBG went to a static version of the RGB Fade like it just stopped at some point and is not changing color anymore.

Ive also tried to flash the RGB software of the Card multiple time with restarting my PC and everything. Every single time this was the output:

              ASRock ISP Tool v1.0.12.2 Built: 20221208
        (C)2019 ASRock Incorporation. All Rights Reserved

[ Configuration ]
Program Interface ...... ADL_I2C_OEM
Adapter ................ AMD Radeon RX 7900 XT

[ Chip - Current]
FW Version ............. 0x00000000
FW Release ............. 0x00000000
FW Feature ............. 0x00000000
HW Version ............. 0x00000000
Device ID .............. 0x00000000
Flash Mode ............. Unknown (0x00)
Config0 : Config1 ...... 0x0040401E : 0x0019FC94

Jump to LDROM                     [ Fail ]
Process Time                      [ 0,03 seconds ]
       Update Fail

I also reinstalled the drivers on my GPU which didnt help.

Here are my specs:
Ryzen 7900X3D
Corsair Vengeance RGB white DIMM Kit 32GB, DDR5-6000
Corsair RMx Series 2021 RM1000x 1000W ATX 2.53
ASRock Radeon RX 7900 XT Phantom Gaming White OC
mounted on a NZXT Vertical GPU Mounting Kit, Riser Card

Currently only installed RGB Software is SignalRBG
Also I dont know if the Vertical Mount with the Riser Cable might be a problem for the rgb firmware flash software?

I would highly appreciate any help <3
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.125 seconds.