ASRock.com Homepage
Forum Home Forum Home > PC Modding > Project Build&Share
  New Posts New Posts RSS Feed - new build, driver issues with ubuntu
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

new build, driver issues with ubuntu

 Post Reply Post Reply
Author
Message
Tonye7777 View Drop Down
Newbie
Newbie
Avatar

Joined: 28 Oct 2016
Status: Offline
Points: 8
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tonye7777 Quote  Post ReplyReply Direct Link To This Post Topic: new build, driver issues with ubuntu
    Posted: 28 Oct 2016 at 2:35am
HI,

We just built our first pc and it worked when we turned it on !!!!!  (there are some problems)

Problems:
incredibly slow, mouse, typing anything - it's slow
vga not coming through on new monitor
wifi signal not detected (ethernet is working)
cannot run the .exe from the cd included with the mother board

I think that drivers have not been loaded and I can't find/figure out how to load them in ubuntu

Motherboard is H110M-DGS

thanks
Tony
Back to Top
wardog View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 15 Jul 2015
Status: Offline
Points: 6447
Post Options Post Options   Thanks (0) Thanks(0)   Quote wardog Quote  Post ReplyReply Direct Link To This Post Posted: 28 Oct 2016 at 3:00am
For starters there's no drivers for Ubuntu(or any Linux variant) on the included CD.

Is this a Live CD you're trying to use, OR, did you go the Install route?
Back to Top
Tonye7777 View Drop Down
Newbie
Newbie
Avatar

Joined: 28 Oct 2016
Status: Offline
Points: 8
Post Options Post Options   Thanks (0) Thanks(0)   Quote Tonye7777 Quote  Post ReplyReply Direct Link To This Post Posted: 02 Nov 2016 at 7:17pm
i installed the os via bootable usb
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 03 Nov 2016 at 12:22am
Originally posted by Tonye7777 Tonye7777 wrote:

HI,

We just built our first pc and it worked when we turned it on !!!!!  (there are some problems)

Problems:
incredibly slow, mouse, typing anything - it's slow
vga not coming through on new monitor
wifi signal not detected (ethernet is working)
cannot run the .exe from the cd included with the mother board

I think that drivers have not been loaded and I can't find/figure out how to load them in ubuntu

Motherboard is H110M-DGS

thanks
Tony


As wardog said, there is no official support for Ubuntu or any Linux version with any ASRock board. You'll find that to be true for any mother board manufacture. The driver disk only contains drivers and software that is Windows compatible.

Drivers and software for the various hardware components in a mother board are provided by the manufacture of the hardware themselves. For example, your board has an Intel H110 chipset, Realtek audio and network chips, and whatever WiFi adapter you are using. Those manufactures provide the drivers and software to the mother board manufactures. Mother board manufactures do not create drivers and software for those components.

If the various hardware manufactures had Linux compatible drivers available, then the mother board manufactures could provide them to you. It's also more complex than that, depending upon the version of Linux being used.

So when someone uses Ubuntu or other variant of Linux, they are on their own providing drivers and other essential software, sorry to say. You'll need to find assistance through the various Ubuntu and Linux websites, such as where you downloaded Ubuntu.
Back to Top
SurfaceUnits View Drop Down
Newbie
Newbie
Avatar

Joined: 31 Oct 2016
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote SurfaceUnits Quote  Post ReplyReply Direct Link To This Post Posted: 03 Nov 2016 at 11:21am
How were the various components working when you booted with the USB stick? Try booting with it again and see if the experience is different.
ASRock Fatal1ty 970 Performance, AMD FX-8310 @4.6GHz + 5GHz Boost, 2x4GB G.Skill 2400 Sniper, 2X MSI Gaming R9 270 Twin Frozr, EVGA 600, Windows 10 64-bit
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.129 seconds.