ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - New build has no screen
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

New build has no screen

 Post Reply Post Reply
Author
Message
elMuro View Drop Down
Newbie
Newbie


Joined: 09 Jul 2024
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote elMuro Quote  Post ReplyReply Direct Link To This Post Topic: New build has no screen
    Posted: 09 Jul 2024 at 1:02am
I just ordered myself a new PC and built it together. When power it on the TV doesnt receive a signal.

All parts should be compactible according to pcpartpicker.

The Build is as following:
MB: Asrock B650E ITX
CPU: AMD Ryzen 5 7600
GC: RTX 3060
RAM: 2x16GB DDR5
SSD: MP700 PRO 2TB

I tried the hdmi from the MB and GC but neither give a signal. My other PC can be displayed on the TV with the same hdmi connection.
Any Ideas?
Back to Top
elMuro View Drop Down
Newbie
Newbie


Joined: 09 Jul 2024
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote elMuro Quote  Post ReplyReply Direct Link To This Post Posted: 09 Jul 2024 at 1:26am
Question: Are there any LED on the Motherboard when it gets powered on? Because the only things which indicate that there is power are the RAM rgbs and the CPU fan spinning
Back to Top
elMuro View Drop Down
Newbie
Newbie


Joined: 09 Jul 2024
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote elMuro Quote  Post ReplyReply Direct Link To This Post Posted: 13 Jul 2024 at 6:41pm
I could solve the problem by refitting the CPU. It seems it wasnt well put inside the mainboard.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.154 seconds.