ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - ASrock Z68 Extreme3 Gen3 won't boot after update
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

ASrock Z68 Extreme3 Gen3 won't boot after update

 Post Reply Post Reply
Author
Message
Penny_xP View Drop Down
Newbie
Newbie


Joined: 17 May 2018
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Penny_xP Quote  Post ReplyReply Direct Link To This Post Topic: ASrock Z68 Extreme3 Gen3 won't boot after update
    Posted: 17 May 2018 at 2:18am
Hi guys,
I recently updated my Asrock Z68 Extreme3 Gen3 to the newest beta BIOS (L.2.31A: https://www.asrock.com/mb/Intel/Z68%20Extreme3%20Gen3/index.asp#BIOS) to enable Fast booting in windows 10. The update itself succeeded without an issue and Instant Flash asked me to press any key after the update has finished to reboot, which I did.
Sadly my PC wont start since then :/ The mainboard doesn't POST and won't display anything. The onboard LED showed code 95 for a few seconds and then it started displaying 10 and 08, rapidly switching between the two numbers (0.1s or so).
I did a CMOS reset with the same result. Then I removed everything (only CPU, one RAM and necessary cables were connected) and did a CMOS reset again, still with the same result.

Is there any chance the board isn't bricked?

System:
Mainboard: Asrock Z68 Extreme3 Gen3
CPU: Intel Core i5 2400
Memory: 4x 2GB Corsair Vengeance 1600Mhz (9-9-9-24)
GPU (PCIe): XFX HD6870 (1GB)
Soundcard (PCI): Creative Soundblaster Platinum
Back to Top
Bronobo View Drop Down
Newbie
Newbie


Joined: 12 Sep 2018
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bronobo Quote  Post ReplyReply Direct Link To This Post Posted: 12 Sep 2018 at 9:32am
Dealing with this as well, did you ever find a solution? Searching google indicates I have to buy a new bios chip with 1.30.
Back to Top
Bronobo View Drop Down
Newbie
Newbie


Joined: 12 Sep 2018
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bronobo Quote  Post ReplyReply Direct Link To This Post Posted: 18 Sep 2018 at 6:58am
Update: Requested v1.30 bios chip from ASRock online support, took 2 days for them to put it together and they shipped it for free! All is well after switching the chips.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.094 seconds.