Print Page | Close Window

ASRock DeskMini X300 memory slot B1 issue

Printed From:
Category: Technical Support
Forum Name: HTPC&Gaming Barebone&Others
Forum Description: Question about HTPC&Gaming Barebone&Others
Printed Date: 18 May 2024 at 8:31am
Software Version: Web Wiz Forums 12.04 -

Topic: ASRock DeskMini X300 memory slot B1 issue
Posted By: kraemer_sg
Subject: ASRock DeskMini X300 memory slot B1 issue
Date Posted: 03 Apr 2022 at 5:05am

my new ASRock X300 does not boot, when memory is installed in DDR4_B1. The power LED is not lid but the CPU fan spins.

When the DIMM is removed from the slot it boots perfectly.

I changed the configuration around (tried different DIMMS, tried, A1 and B1 only, ...) but the system only boots, when only A1 is loaded with a DIMM, the moment a DIMM is installed in B1, no booting.


AMD Athlon 3000G 2x 3.50GHz So.AM4 TRAY
ASRock DeskMini X300 (90BXG3T01-A10GA0W)
2 x 8GB Crucial DDR4-2666 SO-DIMM CL19 Single
500GB KIOXIA Exceria M.2 PCIe 3.0 x4 3D-NAND TLC (LRC10Z500GG8)
Noctua NH-L9a-AM4 Topblow Cooler

IS this a known issues or a hardware defect?


Posted By: threadzipper1957
Date Posted: 05 Apr 2022 at 7:36pm
Hi Stefan,

The memory controller is integrated in the CPU, so there is a direct link between pins of the CPU, and contacts in the memory slot.

One important thing, did you buy 2 separate modules, or a kit of 2?
In a kit, chips on the memory, are produced in the same batch, so identical, with 2 separate modules it can be different.
But from what you write, I understand, that only 1 module in B1 is also not working.
It is not really clear if you tried only B1, and tested with both modules.
It does seem hardware related, but first test each slot individual with 1 module
My guess would be a defective CPU, or maybe a bent pin on the CPU.
If both have been purchased from the same dealer, return the both, so they can test

Kind Regards

Posted By: kraemer_sg
Date Posted: 06 Apr 2022 at 4:28pm
Hi, thanks for the answer. Here is what I tried:

* Both memory modules separately in A1 -> System works
* Both memory modules separately in B1 -> System does not boot, LED off
* Both memory modules in both slots, both ways (two possibilities) -> System does not boot, LED off

Unfortunately, I can't test the components in a different system and X300 cannot be bought anywhere at the moment.

What I will try:

I will take the system apart again and re-assemble to see if that helps. If not, I will run it with one DIMM, as we need the system and wait for the X300 to be available again and buy a second one to check the components.

In the meantime, I bought a 16 GB DIMM to use in A1 to run the system with sufficient memory.

Warranty has not run out yet, so I can wait for a few weeks, return time has run out, as I bought the system in January but only now had the time to assemble it.

I'll keep you posted.


Posted By: threadzipper1957
Date Posted: 06 Apr 2022 at 5:52pm
Hi Stefan,

Retrun period has expired maybe, but in EU, warranty is always between seller and buyer, so maybe the seller still has a replacement.
Did you try, to disconenct the powersupply, then press the start button for 30 or so seconds, after that short circuit the ClrCMOS pins (Nr. 2 in the online PDF manual)

Kind Regards

Posted By: kraemer_sg
Date Posted: 06 Apr 2022 at 6:08pm

I haven't tried that yet, but it is good advice that I will try.

Posted By: threadzipper1957
Date Posted: 06 Apr 2022 at 7:48pm
Maybe it would be best, to use the support form" rel="nofollow -
Depending on language and country, the ticket is forwarded to support in USA, Taiwan, or The Netherlands

Kind Regards

Posted By: kraemer_sg
Date Posted: 07 Apr 2022 at 1:03am
I used the support and received a very similar answer.

Posted By: kraemer_sg
Date Posted: 07 Apr 2022 at 2:09am
I took the mashine apart completely and put it back together: I found no obvious problems, but B1 is still broken...

Posted By: Xaltar
Date Posted: 07 Apr 2022 at 1:10pm
Have you checked for any bent/missing pins on the CPU? If even a single pin is
missing it could easily account for the faulty/missing B channel. As Threadzipper
mentioned, the IMC is on the CPU. Each channel will have it's own separate path
from the CPU to the motherboard, if one of these is not connected then it explains
the issue.


Posted By: jotie
Date Posted: 25 Nov 2023 at 5:03am
Was it in the end a bad motherboard or the processor?
I have a similar issue.


Posted By: jotie
Date Posted: 25 Nov 2023 at 5:24pm
In my case it was the X300 DeskMini motherboard which was broken, I swapped the processor and the issue remained.


Posted By: zillion42
Date Posted: 27 Nov 2023 at 5:32pm

I also have a broken B1 Ram Slot. I double checked the CPU Pins, that really wasn't the problem. Better be careful when inserting SO-Dimms, don't bend the Motherboard, give it counterpressure from below.
Really unfortunate.

Posted By: zillion42
Date Posted: 28 Nov 2023 at 2:23am
Hi again,

I spent the whole day assembling and disassembling the the whole system, and I fixed it on the 6th attempt.
It was in fact a slightly slightly bent CPU Pin. If you look on the CPU, the side that faces the memory banks, the outer pins, that was it for me.

I also used a soft toothbrush with alcohol to completely wipe all thermal paste and used magnifying glasses, headlights and macro photos to help in the process.
I also brushed the socket with the toothbrush and alcohol.

Hope you guys have the patience.

You really don't want single channel ram.

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -