Print Page | Close Window

Steel legend Z790 Wifi - Thunderbolt 4 problems

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=26978
Printed Date: 19 Apr 2024 at 10:29am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Steel legend Z790 Wifi - Thunderbolt 4 problems
Posted By: avtman2
Subject: Steel legend Z790 Wifi - Thunderbolt 4 problems
Date Posted: 12 Nov 2023 at 6:07am
I have an AsRock Steel Legend Z790 Wifi, brand new, and installed an AsRock TB4 AIC into PCIE2 per the instructions. I am trying to connect this to a Presonus Quantum 2626 TB3 audio interface. The TB appears to be working, when I launch the Intel TB Control center, it shows the Quantum as a device, but will not allow me to approve it within the control center, it does say "not connected". In the about section it says that PCIE Tunneling is disabled, and I'm assuming this is my issue, however I looked all through the BIOS and didn't find this setting, but I did enable TB in the BIOS. I also tried 2 different cables with the same results. According to Presonus, they say that this device will work with Intel/TB4 computers. My question is, should PCI tunneling be enabled, and where do I find that? Any help is appreciated, I did submit a support ticket to ASRock, but haven't heard back on it.

Thanks,
Aaron

BIOS Ver: 5.02



Replies:
Posted By: starfield412
Date Posted: 19 Nov 2023 at 6:10pm
Facing a similar challenge with my AsRock Steel Legend Z790 Wifi and TB4 AIC. Experiencing issues with the Intel TB Control Center and the Presonus Quantum 2626. Checked BIOS for TB settings and enabled TB, but struggling to find the PCI Tunneling option. Any insights or solution https://ezaudiobookforsoul.com/" rel="nofollow - For Soul from the community? Appreciate the help.

-------------
asfas515


Posted By: avtman2
Date Posted: 20 Nov 2023 at 2:55am
Hey Starfield,

I think I may have somewhat of a solution to the issues. You're probably on Win 11, make sure all BIOS, GPU, Audio, and GPU updates are done from the site. Also, Win 11 updates, and that your TB setting in BIOS in enabled. I left the other 3 option disabled but that might be for the issue I still have. If all that is done, I believe this is a Window security issue.

My light on the Quantum 2626 was just red, so if you try this an reboot after each change it may come up blue for you.

Go to Windows Security -> Dev ice security -> Core Isolation. Disable memory integrity. Might have to reboot

Go back in and disable Microsoft Vulnerability Driver block list. Reboot with the Quantum on.

My light is blue and the Thunderbolt controller is showing the device and showing connected. Universal Control now sees it and so does Studio One.


I did some audio tests through it yesterday and worked fine, but haven't tested any recording yet.

My issue that I'm having now is, that it only works with the Quantum is started prior to the computer, so if I turn it off and back on the light is red. So I'm still trying to figure that out.

Maybe we can work on this together to try and get the quantum humming with our new machines. Keep in touch.

Aaron


Posted By: avtman2
Date Posted: 20 Nov 2023 at 4:18am
Starfield,

Also, I have a support ticket in with Presonus, they did send this link you might want to turn off the power management to some devices.

https://support.presonus.com/hc/en-us/articles/4411398662797-Optimizing-Your-Computer-for-Audio-Windows-11" rel="nofollow - https://support.presonus.com/hc/en-us/articles/4411398662797-Optimizing-Your-Computer-for-Audio-Windows-11

i know there's a thunderbolt driver in device manager too with power management, I'm unsure turning it off will help, but I think turned mine off as well.

Aaron


Posted By: avtman2
Date Posted: 21 Nov 2023 at 11:47pm
Hey Starfield,

See my replies to your issue, I think I figured it out.

Aaron



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net