ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - AB350 Gaming K4 Sound Blaster Cinema 3
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

AB350 Gaming K4 Sound Blaster Cinema 3

 Post Reply Post Reply
Author
Message Reverse Sort Order
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 8592
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Topic: AB350 Gaming K4 Sound Blaster Cinema 3
    Posted: 20 Aug 2019 at 2:40pm
Dear Aerius,

Greetings, this is ASRock TSD.


Please refer to below link to download Sound Blaster via Microsoft store to check again.
https://www.microsoft.com/en-sg/store/p/sound-blaster-connect/9n66rljrt8z2

If the problem stills the same, please re-install the audio driver on the system.
http://asrock.pc.cdn.bitgravity.com/Drivers/All/Audio/Audio(v8067_FF10).zip

FAQ:
https://www.asrock.com/support/faq.asp?k=sound+blaster    


Thanks!

All the best,
ASRock TSD
Back to Top
Aerius View Drop Down
Newbie
Newbie


Joined: 11 Nov 2017
Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote Aerius Quote  Post ReplyReply Direct Link To This Post Posted: 20 Aug 2019 at 2:23pm
Hello, my system is windows 10 RS5 and when i try to open sound blaster cinema 3 get error message: this audio device is disabled, not present, not supported by the application or it has disconnected jack connections. Do you want to select another audio device now?
So now I am not able to use this function at all. Please help me that how can I install it properly on my board, thanks a lot!!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.117 seconds.