Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Can't install Windows 10 on X570M
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Can't install Windows 10 on X570M

 Post Reply Post Reply
Message Reverse Sort Order
crawlmeister View Drop Down

Joined: 08 Sep 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote crawlmeister Quote  Post ReplyReply Direct Link To This Post Topic: Can't install Windows 10 on X570M
    Posted: 08 Sep 2019 at 5:19am
Found this on a forum that I found by complete accident, this process solved my issue:


Solved the problem.? It was a drive partition recognition issue.? The installer created partitions on the internal m2 drive, but then tried to install on the usb stick.
Here's how I solved it:
1)? Booted to usb installer
2)? Started diskpart (shift-f10 to get a command prompt)
3)? cleaned the internal drive - removing all partition data
4)? converted to GPT - so that it could boot in utfi mode
5)? CREATED a small 10GB partition on the internal M2 drive, formatted it as ntfs, and gave it a drive letter.? Left remaining space on internal drive as 'unallocated'
6)? XCOPY'd the installer files from my usb stick to the new partition
7)? Rebooted the system without the USB stick plugged in.?? The installer booted from the internal drive
8)? Installed windows.? YAY!
9)? Rebooted - and it booted to the installer again, because the partition I created earlier was still the first boot partition in the list
10)? Used diskpart to reformat the small partition I created earlier - so it would no longer be a boot option
11)? Rebooted one more time and everything worked
The installer was able to boot to the partition on my internal disk and started normally.? When? I installed windows on the unallocated space on the drive, the installer did all the right things and windows installed!? Having only one drive in the mix (no usb) was the main issue.? I suspect that it's because the m2 drive is the only internal drive in my system.
The key was finding a method that took the decision of where to install out of the installer's hands.? As long as the USB drive was the primary drive the installer failed to find the correct place to install windows
Back to Top
crawlmeister View Drop Down

Joined: 08 Sep 2019
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote crawlmeister Quote  Post ReplyReply Direct Link To This Post Posted: 08 Sep 2019 at 4:07am
Hi all, going a little crazy build a new PC

Here is the relevant build list:
- ASRock X570M Pro4
- Ryzen 5 3600
- Geforce 2070 Super
- Team Group GX2 SSD

So the issue I'm having comes with trying to install Windows 10. I am able to boot the USB with the image by selecting the "UEFI: SanDisk Ultra PMAP, Partition 2" - If I try to boot the USB it does not recognize the boot media if I try to boot Partition 1 it just goes back to the boot media selection.

Once the menu for windows starts I go through all the setup, custom install and select the SSD to be installed to.

After about 30 seconds and still at 0% installation I get the following error: "Windows could not prepare the computer to boot into the next phase of installation. To install Windows, restart the installation"

I have tried troubleshooting this a few ways with the same results
- Loading the legacy stuff in the CSM boot menu and disabling secure boot
- Reformating the SSD from MBR to GPT
- Other SSD
- Other HDD

I am only able to use a Mac right now since I don't own another PC. Since its the same issue across different SSD's & HDD and the USB does boot windows installation to a point, I can't think of anything other than the Motherboard.

Any advice or suggestion are appreciated!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.188 seconds.