ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X570 Taichi - Uknown USB Device
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X570 Taichi - Uknown USB Device

 Post Reply Post Reply
Author
Message
AndSol View Drop Down
Newbie
Newbie


Joined: 29 Sep 2019
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote AndSol Quote  Post ReplyReply Direct Link To This Post Topic: X570 Taichi - Uknown USB Device
    Posted: 29 Sep 2019 at 3:46am
Hi, I am getting a strange error in my Device Manager:

Unknown USB Device (Device Descriptor Request Failed)
(Standard USB Host Controller)
Port_#0003.Hub_#0002

```
Device USB\VID_0000&PID_0002\8&25f65393&0&3 was configured.

Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Driver Date: 06/21/2006
Driver Version: 10.0.18362.1
Driver Provider: Microsoft
Driver Section: BADDEVICE.Dev.NT
Driver Rank: 0xFF0000
Matching Device Id: USB\DEVICE_DESCRIPTOR_FAILURE
Outranked Drivers: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000
Device Updated: false
Parent Device: USB\ROOT_HUB30\7&11e6caf8&0&0
```

I have tried disconnecting all USB devices from the machine but the error does not disappear.

Please help.
Back to Top
thepower99 View Drop Down
Newbie
Newbie
Avatar

Joined: 26 Nov 2019
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote thepower99 Quote  Post ReplyReply Direct Link To This Post Posted: 26 Nov 2019 at 8:46am
Hi Mate,

Don't know if you ever fixed this, but in case you didn't (and for any others searching) I had the same issue which I have now resolved.

For me the reason was I had the USB header plugged into the AMD supplied cooler (Wraith Prism) as well as the RGB header.

Simply unplugging the USB header fixed the issue for me.

The Taichi manual is quite vague in its instructions for this setup, while it does say only some cables should be plugged in, the picture has all 3 connected (CPU fan connection, USB header connection, RGB header).

I'm not really sure what this USB header is supposed to do, but I have not noticed any difference since unplugging it, besides USB3 now working (which for me it wasn't).

Hope that helps you (or others!)
Back to Top
alexwaston View Drop Down
Newbie
Newbie


Joined: 22 Apr 2020
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote alexwaston Quote  Post ReplyReply Direct Link To This Post Posted: 22 Apr 2020 at 6:24pm
Occurrence of Unknown USB Device (Device Descriptor Request Failed) error is very common. Well, if you are also going through same issue then just relax and calm! You can fix device descriptor request failed error easily. Sometimes, this problem is caused by Power Supply. So, try to remove the power supply to fix this problem. For this follow the below instructions:

1. First, remove the Power Supply plug from PC.
2. Next, re-plug in the Power Supply.
3. Restart your computer and connect the device to the USB port.

For more info: http://www.rescuedigitalmedia.com/fix-unknown-usb-device-device-descriptor-request-failed-on-windows
alexwaston
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.158 seconds.