ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - (Solved)Samsung Evo 970 Plus on Z97 Killer
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

(Solved)Samsung Evo 970 Plus on Z97 Killer

 Post Reply Post Reply Page  12>
Author
Message
mihaela View Drop Down
Newbie
Newbie


Joined: 13 Dec 2019
Location: bucharest
Status: Offline
Points: 70
Post Options Post Options   Thanks (0) Thanks(0)   Quote mihaela Quote  Post ReplyReply Direct Link To This Post Topic: (Solved)Samsung Evo 970 Plus on Z97 Killer
    Posted: 13 Dec 2019 at 6:52am
Hello,
I have a Fatal1ty Z97 Killer mobo and i want to install on it a Samsung 970 EVO Plus, 500GB, NVMe, M.2.

I've read that NVMe is not supported as a boot drive on Z97 chipsets , is it true?

I will install Win 8.1 on it.

Maybe looks like a waste of money but soon i will upgrade the PC and i want to use this SSD.

Thanks

Edited by ASRock_TSD - 04 Feb 2020 at 7:52pm
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 7422
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 18 Dec 2019 at 10:29am
Dear Mihaela,

Welcome to ASRock forum.
It is a great place to get answers for your question.

Regarding your question, yes, Z97 Killer will support 970 EVO Plus.
BIOS is required to be updated to 2.50.

Please note that the speed of M.2 on Z97 Killer will not reach to maximum speed since M.2 slot supports up to speed of Gen2 x2.

If there are any further questions, please fill out the ASRock technical form, they shall provide further assistance.
https://event.asrock.com/tsd.asp?ln=en

With thanks,
ASRock TSD

Edited by ASRock_TSD - 18 Dec 2019 at 10:32am
Back to Top
mihaela View Drop Down
Newbie
Newbie


Joined: 13 Dec 2019
Location: bucharest
Status: Offline
Points: 70
Post Options Post Options   Thanks (0) Thanks(0)   Quote mihaela Quote  Post ReplyReply Direct Link To This Post Posted: 19 Dec 2019 at 3:53am
Thank you very much!
Back to Top
mihaela View Drop Down
Newbie
Newbie


Joined: 13 Dec 2019
Location: bucharest
Status: Offline
Points: 70
Post Options Post Options   Thanks (0) Thanks(0)   Quote mihaela Quote  Post ReplyReply Direct Link To This Post Posted: 19 Dec 2019 at 7:53am
How about this one?
SSD Intel 660p Series 1TB PCI Express 3.0 x4 M.2 2280
I know the speed is limited at 10Gb, but will it work? PCI Express 3.0 x4 in PCI Express Gen2 x2

many thanks
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 7422
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 24 Dec 2019 at 4:12pm
Dear Mihaela,

Thanks for the feedback.

We do not have the 660p series, but we checked similar 600P series M.2 instead.

And it can be detected under the BIOS/Win10.

Hopefully, the information above helps.

With thanks,
ASRock TSD

Edited by ASRock_TSD - 24 Dec 2019 at 4:13pm
Back to Top
JerryWest_44 View Drop Down
Newbie
Newbie


Joined: 29 Jan 2020
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote JerryWest_44 Quote  Post ReplyReply Direct Link To This Post Posted: 29 Jan 2020 at 12:14pm
Originally posted by ASRock_TSD ASRock_TSD wrote:

Dear Mihaela,

Welcome to ASRock forum.
It is a great place to get answers for your question.

Regarding your question, yes, Z97 Killer will support 970 EVO Plus.
BIOS is required to be updated to 2.50.

Please note that the speed of M.2 on Z97 Killer will not reach to maximum speed since M.2 slot supports up to speed of Gen2 x2.

If there are any further questions, please fill out the ASRock technical form, they shall provide further assistance.
https://event.asrock.com/tsd.asp?ln=en

With thanks,
ASRock TSD



I have a Z97 Killer Fatal1ty
SN: 45M0XD018617
BIOS: 2.60

Win 7 - 64 bit
I7-4790
16GB DDR3

Storage: Samsung 840 EVO 250GB via SATA
Video: Onboard

I installed a Samsung 970 EVO plus 1TB into the M2 slot. However, Storage M2 is not recognized by the BIOS; however, the NVME Controller recognized it.

Please advise.

v/r

Joe
Back to Top
JerryWest_44 View Drop Down
Newbie
Newbie


Joined: 29 Jan 2020
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote JerryWest_44 Quote  Post ReplyReply Direct Link To This Post Posted: 30 Jan 2020 at 12:39am
I have a Z97 Killer Fatal1ty
SN: 45M0XD018617
BIOS: 2.60

Win 7 - 64 bit
I7-4790
16GB DDR3

Storage: Samsung 840 EVO 250GB via SATA
Video: Onboard

I installed a Samsung 970 EVO plus 1TB into the M2 slot. However, Storage M2 is not recognized by the BIOS; however, the NVME Controller recognized it.

In addition in the boot options page the 970 EVO plus shows up but the legacy 840 EVO does not.

Please advise.

v/r

Joe
Back to Top
JerryWest_44 View Drop Down
Newbie
Newbie


Joined: 29 Jan 2020
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote JerryWest_44 Quote  Post ReplyReply Direct Link To This Post Posted: 31 Jan 2020 at 1:09am
Originally posted by JerryWest_44 JerryWest_44 wrote:

I have a Z97 Killer Fatal1ty
SN: 45M0XD018617
BIOS: 2.60

Win 7 - 64 bit
I7-4790
16GB DDR3

Storage: Samsung 840 EVO 250GB via SATA
Video: Onboard

I installed a Samsung 970 EVO plus 1TB into the M2 slot. However, Storage M2 is not recognized by the BIOS; however, the NVME Controller recognized it.

In addition in the boot options page the 970 EVO plus shows up but the legacy 840 EVO does not.

Please advise.

v/r

Joe


Solved ---

The M2 status is for M2 SATA SSD cards not NVME. However the NVME configuration page shows the new 970 EVO plus. Since I have Win7 all I needed was to install Samsung's NVME driver (since these are not part of Win7). Once I installed the drivers, all I had to do is initialize the volume and format the new SSD drive via the Disk Manager -- then I cloned a copy of my older 840 EVO to the new 970 EVO. I rebooted and voila. I'm now booted to me new 1TB 970 EVO plus SSD drive.
Back to Top
w3rty88 View Drop Down
Newbie
Newbie
Avatar

Joined: 22 Mar 2020
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote w3rty88 Quote  Post ReplyReply Direct Link To This Post Posted: 22 Mar 2020 at 5:31pm
hello guys :) this is my first post. i bump the thread because I have a similar problem.

http://forum.asrock.com/forum_posts.asp?TID=13895&PID=73713𑿱
Back to Top
mihaela View Drop Down
Newbie
Newbie


Joined: 13 Dec 2019
Location: bucharest
Status: Offline
Points: 70
Post Options Post Options   Thanks (0) Thanks(0)   Quote mihaela Quote  Post ReplyReply Direct Link To This Post Posted: 13 Mar 2021 at 4:13am
Finally I bought a ADATA XPG SX8200 Pro 1TB, NVMe, M.2.
I see it in BIOS under Advanced/ NVMe config NVME tab but i cannot see it under Storage config and my other 2 HDDs are gone.

I have a SATA3 Samsung Evo 840 and 4 other SATA3 HDDs, i see that the mobo can have 6 SATA3, what am I missing£

thanks !

https://ibb.co/pK3jCRQ
https://ibb.co/Z2RY9bN
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.125 seconds.