ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Persistent bluetooth dropping out: B450M/AC AM4
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Persistent bluetooth dropping out: B450M/AC AM4

 Post Reply Post Reply Page  123>
Author
Message
sevengroove View Drop Down
Newbie
Newbie


Joined: 24 Jun 2020
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote sevengroove Quote  Post ReplyReply Direct Link To This Post Topic: Persistent bluetooth dropping out: B450M/AC AM4
    Posted: 24 Jun 2020 at 3:53am
Hi there, I've had my ASRock B450m/ac motherboard for about 3 months now and have always encountered a problem with Bluetooth. I currently have three devices paired to my Windows 10 desktop:
    • Logitech MX Master 3 mouse
    • Speaker
    • Headphones

    The mouse and speaker are the devices that are always on and connected. Very randomly and without warning, my mouse stops responding. The only way I've found to reliably reinstate the connection is to open up bluetooth settings and toggle Bluetooth to "Off" and then back to "On". On this page, the mouse still shows as "connected" even though it is not responsive. Here are the additional troubleshooting tips I've tried:
      • Remove "Intel Wilreless Bluetooth" from Device Manager and reinstall with latest drivers
      • Change Power Management settings so that the computer cannot turn off bluetooth devices to save power. I did this earlier but after a recent Windows/drivers update I no longer see the Power Management tab under any bluetooth device or controller in Device Manager.
      • Change Power Plan settings to "Maximum Performance"
      • Disable the 2.4ghz band on the wireless adapter, because I read somewhere that this helps as well.

      When I tried each of these steps the problem seemed to go away, but it still manages to resurface and varies in frequency (sometimes once in a few days, other times 5 times in 5 minutes). I am at my wit's end here with how to proceed. Any other suggestions?
      Back to Top
      sevengroove View Drop Down
      Newbie
      Newbie


      Joined: 24 Jun 2020
      Status: Offline
      Points: 15
      Post Options Post Options   Thanks (0) Thanks(0)   Quote sevengroove Quote  Post ReplyReply Direct Link To This Post Posted: 24 Jun 2020 at 5:25am
      Update: another way the mouse connection seems to resume is if I play any music. The mouse is back to working almost the same instant I hit play on a music source.
      Back to Top
      ThreeDee View Drop Down
      Senior Member
      Senior Member
      Avatar

      Joined: 24 Jul 2019
      Location: Billings,MT
      Status: Offline
      Points: 2396
      Post Options Post Options   Thanks (0) Thanks(0)   Quote ThreeDee Quote  Post ReplyReply Direct Link To This Post Posted: 24 Jun 2020 at 10:19am
      ..are you grabbing latest drivers directly from Intel?
      |Ryzen 5 5900|ASRock X570 Taichi-BIOS 4.60|2x16GB HyperX Predator RGB 3200@3600 1:1 IF|ASRock RX 6700XT|2 x PCIe 4.0 M.2 Drives for OS & Games|850 WTT Seasonic 80+ Titanium PSU|Noctua NH-D15|
      Back to Top
      datonyb View Drop Down
      Senior Member
      Senior Member


      Joined: 11 Apr 2017
      Location: London U.K.
      Status: Offline
      Points: 3139
      Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 24 Jun 2020 at 7:50pm
      usually this issue can be cleared up by............


      download and install the LATEST amd chipset drivers direct from AMD

      and then use the intel driver support program as threedee suggested
      [url=https://valid.x86.fr/jpg250][/url]

      3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold
      Back to Top
      sevengroove View Drop Down
      Newbie
      Newbie


      Joined: 24 Jun 2020
      Status: Offline
      Points: 15
      Post Options Post Options   Thanks (0) Thanks(0)   Quote sevengroove Quote  Post ReplyReply Direct Link To This Post Posted: 24 Jun 2020 at 10:52pm
      I did get the bluetooth drivers directly from Intel using their Driver & Support Assistant software. Have not tried updating the chipset drivers from AMD directly though, so will give that a go. Thanks.
      Back to Top
      datonyb View Drop Down
      Senior Member
      Senior Member


      Joined: 11 Apr 2017
      Location: London U.K.
      Status: Offline
      Points: 3139
      Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jun 2020 at 12:57am
      i would advise the intel installer again AFTER the amd chipset

      my best guess (experianced/educated)

      is the communication between the cpu/chipset and the wifi/bt card is the weak point
      hence suggesting the chipset drivers first

      it has worked before with this issue /problem
      [url=https://valid.x86.fr/jpg250][/url]

      3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold
      Back to Top
      sevengroove View Drop Down
      Newbie
      Newbie


      Joined: 24 Jun 2020
      Status: Offline
      Points: 15
      Post Options Post Options   Thanks (0) Thanks(0)   Quote sevengroove Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jun 2020 at 1:36am
      Ok, I updated the chipset drivers, restarted the computer etc. Was smooth sailing for about an hour until the problem happened again.
      Back to Top
      sevengroove View Drop Down
      Newbie
      Newbie


      Joined: 24 Jun 2020
      Status: Offline
      Points: 15
      Post Options Post Options   Thanks (0) Thanks(0)   Quote sevengroove Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jun 2020 at 3:35am
      Also tried disconnecting the bluetooth speaker and using a wired connection, but the problem persists. Halpp!
      Back to Top
      datonyb View Drop Down
      Senior Member
      Senior Member


      Joined: 11 Apr 2017
      Location: London U.K.
      Status: Offline
      Points: 3139
      Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jun 2020 at 3:38am
      then i suggest
      uninstall the device in device manager
      and give windows the good old update spin and see if its got a whql driver for the bt card

      is this a combined bt/wifi card?
      [url=https://valid.x86.fr/jpg250][/url]

      3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold
      Back to Top
      sevengroove View Drop Down
      Newbie
      Newbie


      Joined: 24 Jun 2020
      Status: Offline
      Points: 15
      Post Options Post Options   Thanks (0) Thanks(0)   Quote sevengroove Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jun 2020 at 4:40am
      I tried this just now - windows update did not find any new drivers, but when I did 'scan for hardware changes' in device manager, it ended up installing an older version of the driver from april 2019 (the more recent one is oct 2019). So far it seems to be doing fine (but I never know for sure).

      To your question about whether it is combined, I think it is ... it's built in to the motherboard and is not a separate PCI(e) card but I think it is combined.
      Back to Top
       Post Reply Post Reply Page  123>
        Share Topic   

      Forum Jump Forum Permissions View Drop Down

      Forum Software by Web Wiz Forums® version 12.04
      Copyright ©2001-2021 Web Wiz Ltd.

      This page was generated in 0.250 seconds.