ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - J5040-ITX with PCIe SATA Controller Problem
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

J5040-ITX with PCIe SATA Controller Problem

 Post Reply Post Reply
Author
Message
blueshadow View Drop Down
Newbie
Newbie


Joined: 10 Jun 2021
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote blueshadow Quote  Post ReplyReply Direct Link To This Post Topic: J5040-ITX with PCIe SATA Controller Problem
    Posted: 10 Jun 2021 at 9:33pm
Hi everyone

I just bought a J5040-ITX motherboard to upgrade my existing NAS system. As on the old motherboard, I wanted to run Ubuntu from a SATA SSD and connect 4 SATA data HDDs in Software RAID 5. Since the motherboard has only four SATA ports, I added a additional PCI Express SATA Controller (Delock 90392, uses an Asmedia ASM1061R chip). I chose this controller since the board already incorporates a ASM1061 SATA controller.

I connected the SSD to the internal SATA3_1 port and the first two data HDDs to the internal SATA3_A1 and SATA3_A2 ports. The SSD and the two HDDs are recognized and show up in the BIOS and also in Ubuntu.

The other two HDDs are connected to the PCIe SATA controller. Now, the SATA controller does not seem to be recognized in the BIOS. The two HDDs do not show up in the BIOS. In Ubuntu, I also do not see the two HDDs and I do not get the /dev/sd*. However, the in the "lspci" output the controller is listed.

- Has anyone successfully used such a setup with an additional PCIe SATA controller?
- Should the PCIe SATA controller and the two HDDs show up in the BIOS?
- Any tip on what I am missing?

I would appreciate any help.

Thx, blue
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.063 seconds.