ASRock.com Homepage
Forum Home Forum Home > Media&User's Review > AMD Motherboards
  New Posts New Posts RSS Feed - X570 Taichi Razer Killer NIC (I'm done!)
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X570 Taichi Razer Killer NIC (I'm done!)

 Post Reply Post Reply
Author
Message
Hyperstrike View Drop Down
Newbie
Newbie


Joined: 01 May 2021
Location: Chicago, IL
Status: Offline
Points: 150
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hyperstrike Quote  Post ReplyReply Direct Link To This Post Topic: X570 Taichi Razer Killer NIC (I'm done!)
    Posted: 05 Aug 2021 at 10:32am
I'm basically over the Killer NIC on my x570 Taichi Razer.
When it works, it's acceptable.

However, it's ridiculously prone to the NIC just dropping out.
Not powering down (I've turned that off.) But, mid-data-stream, I simply lose network.

Fiddled power management.
Combed the internet for suggestions.
I grabbed the latest drivers from Intel.

I've been screwing with it since mid-April. I had nice, steady performance for about 2 weeks. Enough time to dismantle my old rig. Then this crap started.

RMA'ing the board isn't acceptable. Because I can't afford to have this system down for more than a day.

So I've bought myself a nice Intel NIC, and this should be the end of it.

Killer has always been a "gimmick". And, now that they've been bought out by Intel, they're a pointless gimmick.

ASRock! Just give us on-brand Intel for our Ethernet solution from now on! Make everyone's life easier!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.047 seconds.