ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Graphics Card
  New Posts New Posts RSS Feed - No fan control£ (RX 6650 XT Challenger D 8GB OC)
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

No fan control£ (RX 6650 XT Challenger D 8GB OC)

 Post Reply Post Reply
Author
Message
palingenesis View Drop Down
Newbie
Newbie


Joined: 24 Jul 2022
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote palingenesis Quote  Post ReplyReply Direct Link To This Post Topic: No fan control£ (RX 6650 XT Challenger D 8GB OC)
    Posted: 24 Jul 2022 at 9:54pm
I just got this card, no installation issues but I can't seem to adjust any of the fan controls. Either is off completely, or 100% on when it hits a certain temp.

I've tried the ASRock Tweaker to try get it to sit at certain speeds or kick in at a speed less than max when it hits a certain temperature. Not even the AMD Adrenalin software works with tuning. (Photo below).

https://community.amd.com/t5/image/serverpage/image-id/71060i9374242FEDD5C1C8/image-size/large?v=v2&px=999

Thought I might post here to find a solution or reason for this strange card behavior. Any ideas?
Back to Top
threadzipper1957 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 05 Mar 2022
Status: Offline
Points: 5770
Post Options Post Options   Thanks (1) Thanks(1)   Quote threadzipper1957 Quote  Post ReplyReply Direct Link To This Post Posted: 26 Jul 2022 at 10:38pm
For the card to run properly, you need to have the boards chipset fan installed, right after the installation of the OS.
When the graphics drivers, and tweaktool are installed it should work.
Maybe it would be best to create a support ticket
https://event.asrock.com/tsd.asp
When using a gmail account, check your spam folder for replies
Also mention model MOBO, CPU and BIOS version, and which OS (Pro, Home)
And any other cards installed
Kind Regards
Back to Top
palingenesis View Drop Down
Newbie
Newbie


Joined: 24 Jul 2022
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote palingenesis Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2022 at 6:28am
Originally posted by threadzipper1957 threadzipper1957 wrote:

For the card to run properly, you need to have the boards chipset fan installed, right after the installation of the OS.
When the graphics drivers, and tweaktool are installed it should work.
Maybe it would be best to create a support ticket
https://event.asrock.com/tsd.asp
When using a gmail account, check your spam folder for replies
Also mention model MOBO, CPU and BIOS version, and which OS (Pro, Home)
And any other cards installed


This unfortunately didn't work, I installed the AMD chipset drivers, no dice. ASRock tech support is recommending I send it back.
Back to Top
threadzipper1957 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 05 Mar 2022
Status: Offline
Points: 5770
Post Options Post Options   Thanks (0) Thanks(0)   Quote threadzipper1957 Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jul 2022 at 11:11pm
This would elliminate the graphics card as possible source.
2 cards with the same issue, is highly unlikely
Kind Regards
Back to Top
palingenesis View Drop Down
Newbie
Newbie


Joined: 24 Jul 2022
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote palingenesis Quote  Post ReplyReply Direct Link To This Post Posted: 13 Aug 2022 at 10:59am
I got my replacement from Newegg a few days ago and this card appears to working normally. Previously, with the bad card, I could not set a fan curve at all, no matter the temperature. With my replacement, the fan speeds are normal and I can actually set a fan curve other than on, or off.

So, in short, if you're having similar issues, your card might be bad and I would seek a refund or replacement before the initial warranty is up.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.160 seconds.