ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Stuck on Updating RGB LED firmware
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Stuck on Updating RGB LED firmware

 Post Reply Post Reply
Author
Message
DSD27 View Drop Down
Newbie
Newbie
Avatar

Joined: 25 Nov 2018
Location: Azores
Status: Offline
Points: 168
Post Options Post Options   Thanks (0) Thanks(0)   Quote DSD27 Quote  Post ReplyReply Direct Link To This Post Topic: Stuck on Updating RGB LED firmware
    Posted: 06 Aug 2022 at 10:10am
When I launch ASRock Polychrome RGB it says Updating RGB LED firmware - Do not turn off your system. And it stays there forever, not doing anything. I've uninstalled the software, restarted then installed it again, still the same.
How to fix?
I'm running Fatal1ty B450 Gaming K4 with BIOS 5.30.
Back to Top
threadzipper1957 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 05 Mar 2022
Status: Offline
Points: 5770
Post Options Post Options   Thanks (0) Thanks(0)   Quote threadzipper1957 Quote  Post ReplyReply Direct Link To This Post Posted: 08 Aug 2022 at 4:18pm
Usuaklly this issue is caused by other RGB tools that are running, a famous tool is Ique from Corsair, it simply blocks the ASrock tool.
Best is to uninstall all RGB tools, restart, and then remove all the folders, linked to these tools, and restart again.
Also disable antivirus software for this, so the software is not interrupted.
Next install the ASRock RGB tool, start it, and let it do the update.
Important is that you, after the Windows installation always first install the latest AMD chipset driver
https://www.amd.com/en/support/chipsets/amd-socket-am4/b450
Kind Regards
Back to Top
DSD27 View Drop Down
Newbie
Newbie
Avatar

Joined: 25 Nov 2018
Location: Azores
Status: Offline
Points: 168
Post Options Post Options   Thanks (0) Thanks(0)   Quote DSD27 Quote  Post ReplyReply Direct Link To This Post Posted: 17 Aug 2022 at 6:13am
Originally posted by threadzipper1957 threadzipper1957 wrote:

Usuaklly this issue is caused by other RGB tools that are running, a famous tool is Ique from Corsair, it simply blocks the ASrock tool.
Best is to uninstall all RGB tools, restart, and then remove all the folders, linked to these tools, and restart again.
Also disable antivirus software for this, so the software is not interrupted.
Next install the ASRock RGB tool, start it, and let it do the update.
Important is that you, after the Windows installation always first install the latest AMD chipset driver
https://www.amd.com/en/support/chipsets/amd-socket-am4/b450

I had RGB Fusion 2.0 for the GPU and Armoury Crate/Aura for keyboard and mouse. I uninstalled everything using Revo Uninstaller, restarted, installed Asrock Polychrome, still the same problem.
I performed a clean boot, also didn't work.
I think this is an AsRock problem with the software, this is a Beta version of Polychrome, the only one released for Windows 11.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.125 seconds.