ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X370 Mobo locks up when trying to boot windows 10
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X370 Mobo locks up when trying to boot windows 10

 Post Reply Post Reply
Author
Message
defectedsoul View Drop Down
Newbie
Newbie


Joined: 21 Mar 2023
Location: United States
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote defectedsoul Quote  Post ReplyReply Direct Link To This Post Topic: X370 Mobo locks up when trying to boot windows 10
    Posted: 21 Mar 2023 at 10:26pm
I?m not sure if the mobo is at fault here or not but I?ve been having this issue for about 6 months now. After the bios windows logo pops up and begins to boot for about 5 seconds and then screens go black and the pc locks up
Most recently upgraded I?ve done to my system was new ram and a 5900x cpu (from a 2700x) about a year ago.
It started locking up maybe once every couple weeks then a few times a week and now every time I turn it off after it?s been sitting for a while. Power and reset buttons are unresponsive so I have to flip the switch on the PSU most times it will boot up fine after that but sometimes I have to do that a few times before it will boot. I?ve searched high and low and still haven?t found what exactly it causing this. I?ve found a few others with the same mobo that have the same issue and they don?t know why either.
Has anyone else had this issue? Or know how to fix or know why?
PC specs
Processor - AMD Ryzen9 5900x
Cooler - CORSAIR iCUE H150i ELITE CAPELLIX
Graphics Card - AMD PowerColor RX 6950XT Red Devil
RAM - 32GB Vengeance RGB pro
Power Supply - 1000watt EVGA SuperNOVA G5
Motherboard - ASRock X370 Taichi (Bios 7.30)
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 18278
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 21 Mar 2023 at 11:18pm
I would open up a support ticket with ASRock:

http://event.asrock.com/tsd.asp

If you have links to others experiencing the same issue, include those too. Anything
like this is always helpful for them to know. If it is a common issue of some kind
they will appreciate being made aware of it (if they are not already).

Good luck.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.031 seconds.