ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - New RAM not working with Asrock z270 killer sli/ac
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

New RAM not working with Asrock z270 killer sli/ac

 Post Reply Post Reply
Author
Message
TheFlyingBison View Drop Down
Newbie
Newbie


Joined: 26 Jul 2023
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote TheFlyingBison Quote  Post ReplyReply Direct Link To This Post Topic: New RAM not working with Asrock z270 killer sli/ac
    Posted: 26 Jul 2023 at 10:07am
I recently purchased new RAM. 2x32GB sticks of Mushkin Redline 3600mhz CL18.

After installing this RAM and booting up the PC, my monitors were black and my mouse and keyboard were inactive.



PC specs:
MB: Asrock z270 killer SLI/ac 2.10
CPU: Intel i7 7700k
GPU: GTX 2070 Super
Storage: Samsung 970 and 870 EVO
Old RAM: Corsair Vengance 2x8gb sticks 3000mhz
OS: Windows 10 Version 22H2 (OS Build 19045.3208)

Thanks for any replies.
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 22688
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 26 Jul 2023 at 4:09pm
I am pretty sure that Z270 doesn't support more than 16gb modules. You can try
contacting ASRock Tech Support and asking them to be certain:

http://event.asrock.com/tsd.asp

Good luck
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.145 seconds.