ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X570S not recognizing SATA DVD drive
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X570S not recognizing SATA DVD drive

 Post Reply Post Reply
Author
Message
Cyberdodo View Drop Down
Newbie
Newbie


Joined: 09 Jan 2024
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote Cyberdodo Quote  Post ReplyReply Direct Link To This Post Topic: X570S not recognizing SATA DVD drive
    Posted: 09 Jan 2024 at 5:44am
I'm building a new computer using the X570S mother board and 5700X CPU.

But I have one problem. This motherboard isn't detecting any SATA optical drives. I've tried 2 drives - the new Blu-Ray writer I bought for this computer, and the DVD writer from my old computer. Both drives have power, but neither one shows up in Windows Device Manager. I've also used 2 different SATA cables, just in case.

Are optical drives not supported by this motherboard?
Back to Top
Cyberdodo View Drop Down
Newbie
Newbie


Joined: 09 Jan 2024
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote Cyberdodo Quote  Post ReplyReply Direct Link To This Post Posted: 09 Jan 2024 at 9:21am
Just an update, I got my optical drive working. Though why it wasn't is still weird.

I have a SSD plugged into SATA #1 and a HDD into SATA #2.
I had been plugging my optical drive into SATA #6 to make sure that it would be the last disk even if I add more HDDs, but the optical drive wasn't working there, nor in SATA #5.
However, I just now tried SATA #3, and now the BIOS finally sees it, and it's there in Windows now.

So, problem solved. But it is still weird that #5 and #6 are not working. This has never happened to me before. Oh well.
Back to Top
jdillipl View Drop Down
Newbie
Newbie


Joined: 03 Aug 2017
Location: USA
Status: Offline
Points: 159
Post Options Post Options   Thanks (0) Thanks(0)   Quote jdillipl Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jan 2024 at 2:09am
Per:

https://pg.asrock.com/mb/AMD/X570S%20PG%20Riptide/index.us.asp#Specification

If M2_2 is occupied by a PCIE-type M.2 device, SATA3_5_6 will be disabled. Do you have M2_2 occupied? Full specifications with all hardware would be helpful.
Asrock X370 Killer SLI/ac, Amd Ryzen 7 1700, GSkill FlareX F4-2400C16D-32GFX, RaidMax Thunder V2 735W PS
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.172 seconds.