ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - ASRock Sapphire
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

ASRock Sapphire

 Post Reply Post Reply Page  123>
Author
Message Reverse Sort Order
dantz View Drop Down
Newbie
Newbie


Joined: 09 Jul 2017
Location: NZ
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote dantz Quote  Post ReplyReply Direct Link To This Post Topic: ASRock Sapphire
    Posted: 04 Sep 2017 at 10:03pm
Originally posted by zlobster zlobster wrote:

Originally posted by dantz dantz wrote:

I see.. updated to 3.1 bios and Asrock Saphire boost now works.


I have a 580 NITRO+ and I always had the logo during boot. There is an ON/OFF switch in UEFI, but how exactly is it working? What is it doing?


Yeah because you have a Sapphire video card the option in bios gives a small boost in GPU performance but the button in A tuning is a +.2 ghz overclock from base frequency on my 1700x

Edited by dantz - 04 Sep 2017 at 10:04pm
Back to Top
zlobster View Drop Down
Groupie
Groupie


Joined: 02 Sep 2017
Status: Offline
Points: 403
Post Options Post Options   Thanks (0) Thanks(0)   Quote zlobster Quote  Post ReplyReply Direct Link To This Post Posted: 03 Sep 2017 at 8:19pm
Originally posted by dantz dantz wrote:

I see.. updated to 3.1 bios and Asrock Saphire boost now works.


I have a 580 NITRO+ and I always had the logo during boot. There is an ON/OFF switch in UEFI, but how exactly is it working? What is it doing?
Back to Top
dantz View Drop Down
Newbie
Newbie


Joined: 09 Jul 2017
Location: NZ
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote dantz Quote  Post ReplyReply Direct Link To This Post Posted: 01 Sep 2017 at 3:40pm
I see.. updated to 3.1 bios and Asrock Saphire boost now works.
Back to Top
dantz View Drop Down
Newbie
Newbie


Joined: 09 Jul 2017
Location: NZ
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote dantz Quote  Post ReplyReply Direct Link To This Post Posted: 29 Aug 2017 at 12:09pm
So I update A tuning and see this does nothing afaik but reset the pc when pressed also they spelled Sapphire wrong.


Edited by dantz - 29 Aug 2017 at 12:11pm
Back to Top
Ronin4740 View Drop Down
Newbie
Newbie
Avatar

Joined: 28 Mar 2017
Location: Reno
Status: Offline
Points: 26
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ronin4740 Quote  Post ReplyReply Direct Link To This Post Posted: 18 Apr 2017 at 6:20am
Originally posted by patchfile patchfile wrote:


I have already had 4 people drive to my home just to watch our computers boot up with the new logo. At least one of them will be buying an ASRock board and a Sapphire GPU just to have the logo. So it is a good partnership, that will help you get a few sales at the very least.

I personally think the logo looks amazing. I am thinking of getting a better camera so I can get a picture good enough to use as a background.

Kinda makes me wished I'd bought a Sapphire card rather than a Powercolor one when I was spec'ing out the components.  If I'd known and the price difference for the RX480 had been negligible I certainly would have!
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 14 Apr 2017 at 10:44pm
Originally posted by patchfile patchfile wrote:

 X370 Killer/ac also has an updated Logo "ASRock-Sapphire" I know it matters not at all, but I do like it.



It's not a bug, it's a feature!


Edited by parsec - 14 Apr 2017 at 10:45pm
Back to Top
patchfile View Drop Down
Newbie
Newbie
Avatar

Joined: 12 Mar 2017
Status: Offline
Points: 26
Post Options Post Options   Thanks (0) Thanks(0)   Quote patchfile Quote  Post ReplyReply Direct Link To This Post Posted: 14 Apr 2017 at 9:25pm
Originally posted by ASRock_TSD ASRock_TSD wrote:

Dear patchfile,

Greetings, this is ASRock TSD.


This is our cooperation with SAPPHIRE VGA manufacture.

When installing SAPPHIRE VGA card like RX460, RX470, RX480, it would show "ASROCK | SAPPHIRE" logo at post screen.

But when installing other brands VGA card would only show ASRock logo.

It is a normal behavior, please feel free to use.


Thanks!

All the best,
ASRock TSD



I have already had 4 people drive to my home just to watch our computers boot up with the new logo. At least one of them will be buying an ASRock board and a Sapphire GPU just to have the logo. So it is a good partnership, that will help you get a few sales at the very least.

I personally think the logo looks amazing. I am thinking of getting a better camera so I can get a picture good enough to use as a background.
Back to Top
datonyb View Drop Down
Senior Member
Senior Member


Joined: 11 Apr 2017
Location: London U.K.
Status: Offline
Points: 3139
Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 13 Apr 2017 at 8:36pm
thats good to know

as i would have found it funny to have a boot screen for my system saying
asrock-asus
LOL


in my defence i just wanted a rx480 and asus done the best value one i could find (also the white one to match my taichi board)

[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 23303
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 13 Apr 2017 at 2:49pm
This is great news, ASRock and a GPU partner working together could only be good for both Big smile
Back to Top
Nemesis.ie View Drop Down
Newbie
Newbie


Joined: 02 Apr 2017
Location: Ireland
Status: Offline
Points: 45
Post Options Post Options   Thanks (0) Thanks(0)   Quote Nemesis.ie Quote  Post ReplyReply Direct Link To This Post Posted: 13 Apr 2017 at 2:47pm
Nice. :) I like it.
Back to Top
 Post Reply Post Reply Page  123>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.142 seconds.