ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X370 Taichi BIOS 2.00 Problem
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X370 Taichi BIOS 2.00 Problem

 Post Reply Post Reply Page  <12
Author
Message
sambalter View Drop Down
Newbie
Newbie


Joined: 03 Apr 2017
Status: Offline
Points: 22
Post Options Post Options   Thanks (0) Thanks(0)   Quote sambalter Quote  Post ReplyReply Direct Link To This Post Posted: 14 Apr 2017 at 2:29am
Originally posted by taichidude taichidude wrote:

Hi Sam--The issue for me is not the same as your issue unfortunately. My issue was that the Windows x64 BIOS Flash utility this time did not work. I tried all the tricks and a few on top of that. While I had no other processes going on in the background it was just bad luck that it made the board go into an infinite loop and no option for bypassing. As other users have noted, do not use the Windows BIOS flash utility unless it is a last resort. My error as I was very tired and lazy that day that cost me more in time and some money than I anticipated. Remember, there are no alternatives to BIOS recovery for this board. It is soldered onto the board so you can't just purchase a new one, not sure why this is the course of action they took with it being bleeding edge technology, but I am sure it was for expediency and that the Rev V2 may have a BIOS recovery option. Overall, if you cannot go through your retailer, RMA via ASRock and they will take care of you and the new board they will send to you will carry the same warranty. One more thing, if you RMA via ASRock, cannabalise that board (i.e. BIOS battery, backplate, etc.) as they will ONLY send you the motherboard.

taichidude, I updated BIOS under Windows, when the program finished, I reboot the computer, and now my computer don´t send signal to monitor and I can see nothing. Dr Debug show these codes cycling (same like you said [54,55...etc]:

This is my video in youtube.


I don´t know why your issue is different to my issue. 

I am contacting with Asrock, waiting answer....

Like you I have learnt this lesson, my next motherboard must have Dual Bios or something to recovery BIOS, this will be my first filter to choose in future...

Excuse me if I have mistakes in my english


Edited by sambalter - 14 Apr 2017 at 2:31am
Asrock Taichi - Ryzen 1700x - RAM KFA2 HOF DDR4-3600 16Gb(8x2)
Back to Top
sambalter View Drop Down
Newbie
Newbie


Joined: 03 Apr 2017
Status: Offline
Points: 22
Post Options Post Options   Thanks (0) Thanks(0)   Quote sambalter Quote  Post ReplyReply Direct Link To This Post Posted: 18 Apr 2017 at 1:43am
Please Asrock, could you give me feedback about my problem? I send email 5 days ago. 

My dealer told me that this problem not is RMA because of it is a problem after update BIOS. So what have I to do?? throw the motherboard in the trash?? I need feedback please.

English isn´t my first language, so please excuse any mistake.

Asrock Taichi - Ryzen 1700x - RAM KFA2 HOF DDR4-3600 16Gb(8x2)
Back to Top
GenesisDoes View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Apr 2017
Status: Offline
Points: 54
Post Options Post Options   Thanks (0) Thanks(0)   Quote GenesisDoes Quote  Post ReplyReply Direct Link To This Post Posted: 18 Apr 2017 at 4:38am
Originally posted by sambalter sambalter wrote:

Please Asrock, could you give me feedback about my problem? I send email 5 days ago. 

My dealer told me that this problem not is RMA because of it is a problem after update BIOS. So what have I to do?? throw the motherboard in the trash?? I need feedback please.

English isn´t my first language, so please excuse any mistake.

< ="chrome-extension://hhojmcideegachlhfgfdhailpfhgknjm/web_accessible_resources/index.js">

If you're in the U.S. or Europe, maybe try calling them. My email replies from customer support take a while. http://www.asrock.com/general/about.asp?cat=Contact
Taichi X370, Ryzen 1700 @ 4ghz, 32GB G.Skill TridentZ Ram, Samsung 960 EVO nvme, Intel 600P nvme, 2TB Seagate HDD, 2TB Hitachi HDD, 1TB Mushkin SSD, GTX 1080
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.156 seconds.